Support » Plugins » OpenID provider not working

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the exact same problem.

    I deleted the plugin, removed whatever I could find from the database, disabled all plugins, switched to the default theme, installed the plugin again but the same problem occurred.

    The other parts of the plugin work fine. I can login to WordPress using another OpenId and people can leave comments, I just can’t login to other sites with my OpenId (from my wordpress). I tried the full author-url and the domain-name and checked the settings to make sure, but nada 🙁

    Same, not OpenID provider is not working. Consumer works fine, though.

    Having the same problem here.

    Also, hi cloakable!

    Kristina Tracer


    Same problem here. I’ve filed a bug report with DiSo, but no word back yet.

    I did a bunch of testing and found that on my Dev server, the plugin worked fine (same version of the plugin and XRDS) but my production server does not.

    The difference? My Dev server is running Ubuntu 9.04 (PHP version: 5.2.6-3ubuntu4.5), and my production server is running 10.04 (PHP version: 5.3.2-1ubuntu4.2).

    This is likely an incompatibility with PHP 5.3. I will dig into their code and post a fix if I find one.

    Confirmed! This bug is caused by incompatibility with PHP 5.3. To fix it, open up the following file:

    <WP DIR>/wp-content/plugins/openid/Auth/OpenID/Server.php

    Search for all instances of &$
    Replace with $

    That seems to have done the trick for me! 😀



    This helped a lot!

    Whenever I try to use it now and haven’t used the site before, it’ll ask for permission and after that it goes blank. When I manually add the site to the list of trusted sites, it works though.

    Trying to figure out if I can get that to work too, but at least this way I can use it again.

    Thanks Soleil!

    Will Norris


    for some reason I can’t commit to the wordpress plugin repository, but try this v3.3.3 release:

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘OpenID provider not working’ is closed to new replies.