Support » Fixing WordPress » OpenID Provider for WordPress MU

  • Resolved mvstudio

    (@mvstudio)



    Hello everyone.
    I’ve installed the OpenID Provider for WordPress MU by Automattic http://wordpress.org/extend/plugins/mu-open-id/ in my self hosted wordpress to use my own URL as OpenID. The mod works fine for posting on a variety of blogs. My issue with this mod is my ID or the nickname used to leave a comment on other blogs comes out out as “blog” and no matter what I change, is there any way to change this ID/nickname?

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Anyone around???

    Mostly it seems that questions to ‘Net help fora result in some combination of eerie silences and advice such as “did U try googling?” I’ll try to be more helpful than that.

    mu-open-id was designed to be used with the multi-user version of WordPress. My guess is that you’re plugging it into reg’lar ol’ WordPress, that you’ve installed WordPress in a directory named “blog”, and that in a resulting confusion mu-open-id is treating the directory name as the username, and unable to substitute a nickname for that username.

    I used phpMyID to create an OpenID server on my own site. One may find useful supplementary discussion on this at InterWingly.net.

    Thank you oeconomist. I just wish whoever wrote the mod would just get this fixed or post the necessary changes for this to work properly for single users.

    I’m going to delete this mod and install the one you mention.

    Sorry for the double post.

    The latest release of the OpenID plugin now supports providing OpenIDs as well as accepting. It <i>should</i> work on both WordPress and WordPress MU, but single-user WordPress has certainly received a lot more testing.

    I am sorry, but I disagree to say that this issue has been resolved. I have the same issue as that of the initial description where in my ID or the nickname used to leave a comment on other blogs comes out out as “blog” and no matter what I change.

    Appreciate any help on this.

    After a week of going back and forth, cursing at my computer and trying to find out why on earth this OPENID plugin was not working I finally found the why today, actually a few minutes ago.

    I tried deactivating all the plugins I had installed just to make sure it was not a incompatibility issue, but that was not the case, the problem was actually with SSL. I have FORCE_SSL_ADMIN in my configuration file set to true. While trying to leave comments with my openID on other blogs I was seeing a huge URL on the browser every time the comment posting failed and noticed some https, so I changed the true value of the SSL to false in the configuration file and the openID plugin finally works. I was able to leave a comment on a friends blog just a couple minutes ago.

    I don’t know if all the people that have been having problems with the openID plugin uses SSL for their admin area, but in case you guys do, try to disable SSL for admin and see if that makes a difference.

    Cheers!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘OpenID Provider for WordPress MU’ is closed to new replies.