WordPress.org

Support

Support » Plugins and Hacks » OpenID login failed: Invalid openid.mode \’\’

OpenID login failed: Invalid openid.mode \’\’

  • I’m running WP 2.7.1 (managed via svn). I have OpenID 3.2.1 and XRDS-Simple 1.0 installed. According to the OpenID status information, overall plugin status is OK.

    Anytime I or any of my readers attempt to login with OpenID we see the error:

    OpenID login failed: Invalid openid.mode \'\'

    I’ve tried deactivating the plugins and altering/resaving the configuration with no luck. Any other tips anyone might have to get this solved?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same thing happening here on WP 2.7.1 with OpenID 3.2.1 as well.

    this is a problem when using various techniques to get “pretty URLs” with non-Apache web servers. It’s been fixed in trunk and will be in the 3.2.2 release.

    bveenstra
    Member

    @bveenstra

    Just tried with 3.2.2, same error occurred on WP 2.7.1 and openid.com

    I can confirm the issue with 3.2.2 and WPMU 2.7.1. FWIW, I’m running lighttpd.

    phyreblade
    Member

    @phyreblade

    Any news on this? I am also having the exact same issue.

    OpenID login failed: Invalid openid.mode “

    WP 2.7.1, OpenID 2.3.3, XRDS-Simple 1.0.

    Better to upgrade again to 2.8, let see guys.

    No luck with 2.8:

    ERROR: The username field is empty.
    OpenID login failed: Invalid openid.mode ”

    I get the same error with WP2.8 and OpenID 3.2.2, but with XRDS-Simple disabled.

    Does anyone posting here have GMP support on their server? I don’t, and that stops the plugin from acting as a provider. It might be what’s stopping it from acting as a consumer too.

    (You can check for GMP at Settings > OpenID > Troubleshooting > “Toggle More/Less”.)

    There has to be either something wrong with the plugin or a setup step that the plugin Author forget to add. I get the error mentioned in the initial post and can’t get the OpenID for author to work.

    OpenID login failed: Invalid openid.mode \'<No mode set>\’ same deal! any solutions, yet?
    WP 2.8.4
    OpenID 3.2.3

    ioni
    Member

    @ioni

    Solution is easy:

    It appears that OpenID was triggering a mod_security rule set by the hosting company. Simple letter rto support solved mine.

    However, the issue is ver yspecific and may not be recognised straight away by the support personnel, so I suggest you check here:

    http://ioni2.com/2009/wordpress-openid-login-failed-invalid-openid-mode-no-mode-set-solved-for-both-wordpress-and-drupal/

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘OpenID login failed: Invalid openid.mode \’\’’ is closed to new replies.