Support » Plugins » OpenId Could not discover an OpenID identity server endpoint

  • Hi
    I just installed the latest openid plugin (3.1.4) on my blog (2.5.1), however, i cannot get the registration/login to work.

    when I register, i always get this error:

    ERROR: Please enter a username.
    ERROR: Please type your e-mail address.
    ERROR: Could not discover an OpenID identity server endpoint at the url:

    Here’s the status info of my blog server:

    Status information: All Systems Nominal (Toggle More/Less)

    [INFO] PHP version: 5.1.6
    [INFO] PHP memory limit: 40M
    [INFO] Include Path:
    [INFO] WordPress version: 2.5.1
    [INFO] PHP OpenID Library Version: 2.1.2
    [INFO] MySQL version: 5.0.62
    [INFO] WordPress’ table prefix: wp_
    [OK] Curl Support: Version 7.12.1. SSL: OpenSSL/0.9.7a. zlib: Supports: ftp, gopher, telnet, dict, ldap, http, file, https, ftps.
    [OK] Big Integer support: GMP is installed.
    [INFO] Plugin Revision: 518
    [INFO] Plugin Database Revision: 24426
    [INFO] XRDS-Simple: XRDS-Simple plugin is installed.
    [OK] Overall Plugin Status

    Is there anything else I need to watch out?

    Thanks for your help. Sydney

Viewing 3 replies - 1 through 3 (of 3 total)
  • that’s really strange… your blog doesn’t seem to detect OpenIDs using identifier select. Nothing comes to mind immediately, but I’ll look into it.

    I’ve been trying to figure out how to use openid and it’s so confusing. I just don’t know enough to understand all the terminology. I went to this site but came away with more questions than answers:

    what is a URI ?? is it when you use a url as an i.d.?
    what is autodiscovery?
    what is an identity provider?
    how come after installing the open id plug-in to my blog it doesn’t work? (what setting am I missing?)

    From the wordpress settings menu: what does this mean:

    “Authorized accounts on this blog can use their author URL (i.e. as an OpenID. The Blog Owner will be able to use the blog address ( as their OpenID. If this is a single-user blog, you should set this to your account.”

    How do I “set it to my account”? How come it ISN’T set to my account??

    I’m new to blogging so I don’t understand much about the big picture, about all the options, about how people use blogs… I want to learn but my usual self-teaching approach is failing me, I’ve been using computers since 1995 (my first was a used IBM XT) — the learning curve has never been steeper. Amazing.

    I do know if someone out there is willing to be patient and fill in a few of the gaps for me I’ll figure out the rest… anyone?

    unresolved as of this post, similar problem being tracked here: other support ticket

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘OpenId Could not discover an OpenID identity server endpoint’ is closed to new replies.