WordPress.org

Support

Support » Plugins and Hacks » OpenID 3.0 – no login-button

OpenID 3.0 – no login-button

  • using the latest openid 3.0 with wordpress-mu 2.6.2 and activated xrds-simple, the openid-plugin doesn’t seem to enhance any of my regular forms by an openid-field (login-field still only has “login” and “password”). However, my admin-menus are properly extended by the openid-options.

    Do I have to manually enter the inputfield in the theme-template? What would be the code for that?

    Thanks in advance,
    Lars

Viewing 9 replies - 1 through 9 (of 9 total)
  • Since the login page is shared by all wpmu blogs, I believe the plugin needs to be installed in the “mu-plugins” folder rather than “plugins”. Of course, this forces it on all the blogs, which is not necessarily ideal. For now, I think it’ll have to be used that way, but I’ll see about fixed that in a future release… that it will enable OpenID on the login form, but individual blogs will have the option of using OpenID on their comment form.

    on second thought… that may not be the problem. I’m able to get it working, installed in either “plugins” or “mu-plugins”.

    neither one works for me. From what I understand, the openid/wp-login.php will extend the default wp-login.php by the openid-field, so nothing has to be done. Could you check if I did something wrong?

    (1) copy xrds-simple and openid in wp-content/plugins/
    (2) activate xrds-simple
    (3) activate openid
    (4) enter openid-provider and other stuff

    The status looks like this:

    [INFO] PHP version: 5.2.1
    [INFO] PHP memory limit: 128M
    [INFO] Include Path:
    
        * /var/www/[domain]/wp-admin
        * /usr/share/php5
    
    [INFO] WordPress version: 2.6.2
    [INFO] MySQL version: 5.0.38
    [INFO] WordPress' table prefix: wp_
    [FAIL] Curl Support: This PHP installation does not have support for libcurl. Some functionality, such as fetching https:// URLs, will be missing and performance will slightly impared. See php.net/manual/en/ref.curl.php about enabling libcurl support for PHP.
    [OK] Big Integer support: BCMath is installed (though GMP is preferred).
    [INFO] Plugin Revision: svn-518
    [INFO] Plugin Database Revision: 24426
    [INFO] XRDS-Simple: XRDS-Simple plugin is installed.
    [OK] Overall Plugin Status

    Anything I forgot to do or something? Thanks in advance!

    there appears to be a problem with the PHP include_path on some hosts, though I can’t quite figure out the cause. The short-term solution would be to rename the wp-login.php that is inside the OpenID plugin to something like login.php. You’ll then need to update the require_once statement inside openid.php to match whatever the new name of the file is.

    Fresh openid 3.0 plugin install:

    Same problem here, your workaround didn’t work. apache log prints out some error looking like database errors. i am wondering if installation script works proberly. Errors:
    Unknown column ‘openid’ in ‘where clause’ for query SELECT comment_ID, comment_post_ID from wp_comments WHERE openid=’1′ OR comment_type=’openid’ made by openid_migrate_old_data, referer: http://www.example.com/wp-admin/plugins.php

    hope you find a fix soon. thx

    @resmo: that’s not causing this problem… just means that the data migration has already happened, so it’s failing the second time. I need to clean that up so it doesn’t cause an error, but it’s not actually doing any harm. By the way, are you also using WordPress MU, or single-user WordPress?

    I have that behaviour on single-user WordPress. Upgraded through the automatic upgrade and all of a sudden I was unable to login with my OpenID 🙁

    @cvd1979: have you tried renaming the file, like I recommended a few comments back? Did that not work for you? If not, then I’ll have to keep investigating what the problem is.

    I have the exact same problem on several of the blogs I run and manage. They are running on VPS boxen running CentosOS 5. They all worked fine with the v2.x series and broke when I upgraded to 3 (which I also did by automatic upgrade in case that’s significant in tracking down the bug)

    Anyway your suggestion to rename wp-login.php works like a dream.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘OpenID 3.0 – no login-button’ is closed to new replies.