open_basedir restriction with media files after upgrade to 3.6 (3 posts)

  1. I run a subdomain multisite network with about 50 sites. After the upgrade to 3.6, ONE site is showing multiple errors like this in the "Right Now" section of the dashboard:

    Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/nfs:/tmp:/usr/local:/etc/apache2/gs-bin:/usr/bin/zip) in /mysite.com/wp-includes/functions.php on line 1345

    This site is almost 4 years old, but was migrated into the multisite (just as other sites have been) with no issues about four months ago. All the media files appear to be uploading to the correct directory, including the files after the migration.

    I have tried changing the theme, and deactivating all the plugins, but still have errors.

    The same errors appear for each media file that has been uploaded-- even the ones uploaded years ago. The errors also appear at the top of any page/post edit page, and the upload media page.

    I'm not able to upload any new media to this one site, but other sites in the install are fine.

    Some of the forum posts I'm seeing indicate that this is a problem with upload directories. But I can't figure out how to fix this, since the same wp-includes/functions.php file seems to be working fine for all the other sites in the install.


  2. My hosting company says that this issue is PHP settings restricting access to files/directories.

    Why would this only affect one or two sites in a multisite install? (I now have a second affected site that I'm aware of--one that has been a part of the multisite for years, so migration is not the source of the problem!)

    I don't really know what I'm doing with resetting file permissions in php.ini (suggested by my hosting company), and I don't want to set them too broadly and create security issues.


Topic Closed

This topic has been closed to new replies.

About this Topic