WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Open local file not url

[Resolved] Open local file not url

  • Responding to your comment reply to this:
    http://wordpress.org/support/topic/404-on-import-on-in-test-environment?replies=3#post-3866208

    Actually, it was as simple as changing lines 401 and 402.

    From: $widget_settings[‘url’]

    To: $widget_settings[‘file’]

    Seems to work so far. It found the file at least.

    I’m glad you were able to answer your own issue with the plugin. Unfortunately, since this is an edge case as you had said, I will not be integrating this into future versions of the plugin.

    I’m going to be marking this topic as resolved, but if you need further assistance, feel free to open another.

    Can you explain good justification for opening the file via url? If you’re uploading a file and have the local handle, why go back out over http and open it that way? Especially considering it breaks in local installs or if you have http auth enabled (ie staging servers)

    This is a bug, and a simple one at that to fix. Why no willingness to fix?

    I was just about to fix and submit a patch to you, but your comment left a bad taste in my mouth. I hope you reconsider.

    http://wordpress.org/extend/plugins/widget-settings-importexport/

Viewing 1 replies (of 1 total)
  • Plugin Author Kevin Langley

    @kevinlangleyjr

    I apologize for leaving a bad taste in your mouth saying that, as it wasn’t my intention at all. It is honestly, just the fact that I’m busier than hell lately and finding the time to get to my plugins have been hard. I’ve made the exact change you requested in the latest version and I hope this fixes your issues and leaves us in a better standing.

    Let me know if you’re still having issues with the latest version.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Open local file not url’ is closed to new replies.