Support » Plugin: Elementor Page Builder » Open link in new tab doesn’t work?

  • Resolved taco100

    (@taco100)


    Hi there

    In this page I have set the headlines above the pictures as hyperlinks and set them to open in new window.
    And it doesn’t do that (after cleaning the cache of course).
    Any suggestions?

    Thanks!
    Tal

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author ArielK

    (@arielk-1)

    Go to your dashboard > Accessibility plugin settings > switch the setting of “Remove target attribute from links” to Disable

    Thanks Ariel
    Did it (who would have thought to look there?) – but it still doesn’t do the job 🙁

    Plugin Author ArielK

    (@arielk-1)

    Did you set the link with target_blank?

    Hi Ariel
    The problem is now only at the headline element: “מלון THE HOTEL AT TIMES SQUARE” – I have set this element using the Elementor interface, over there clicked the “Open in new tab” button next to the target URL and hit save.
    Did I’ve answered your Q?

    (P.S. in the other headline “מלון La Quinta Inn” at the same page I have un-clicked the “open in new tab” just to make sure that I’ve ‘clicked it to the right direction’, and this headline also doesn’t open up in new tab..)

    Plugin Author ArielK

    (@arielk-1)

    Unfortunately it looks like our bug, we release a version update soon.
    (0.10.4 fix – https://github.com/pojome/elementor/pull/750/files)

    Thanks for your report!

    • This reply was modified 3 years, 1 month ago by ArielK.

    Hi Ariel

    Thanks for your quick and positive reply!

    Please please kindly add an option to mark any element hyperlink / text hyperlink as nofollow,
    Or just add an option to add any parameter the user will need (nofollow or any other) to text and elements hyperlinks.
    OR don’t block the “Ultimate nofollow” plugin from working in Elementor (I have described it in another support post few days ago with Boaz)

    Thanks again (great builder!)
    Tal

    Plugin Author ArielK

    (@arielk-1)

    In the text editor widget you can edit the link in the plain text mode and add rel=”nofollow” to the link.

    For other link controls we need to figure out how to do this perfectly like WP editor. It will take some time 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Open link in new tab doesn’t work?’ is closed to new replies.