• Resolved bsthp


    Can anyone please confirm where i can set the system to open links in a new broswer window/tab?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hello,

    I have already open a ticket about this problem here :

    It’s since release 4.13.2.

    You can downgrade to 4.13.1 to solve the problem or wait for a new release.


    Looks like it should be under Link Preferences => Open links behaviour in the template but it’s not working for me.

    Temporary workaround:

    I had to add the ‘target’ attribute with some JS.

    document.querySelectorAll( 'li.wpra-item.feed-item a' ).forEach( function( link ) {
    			link.target = "_blank";
    		} );

    Thank you both for your replies. Mark, can you please confirm which file the code has to be inserted into and also where in the file?

    Plugin Author Mark Zahra


    Hey folks, as mentioned in some other threads, we’re unable to reproduce this issue on any of our own websites.

    @machouinard could you share how and where you added this workaround, please?

    We would also like to check whether your sites have anything specific in common. Would you each mind sharing some of the details below:

    1. The theme being used on your site.
    2. The RSS feed/s you are importing from.
    3. A screenshot of your template settings.

    Mark, screenshot of Settings, template Settings and Feed settings; https://www.accountant-resource.co.uk/rss%20screenshot.jpg


    We’re using a custom plugin for various things on this site with a JS file already enqueued. As a temporary solution I simply added a function with the above code and am calling it on $(document).ready and ajaxComplete.

    I’ll provide settings/feed detail and screenshot when I’m back at my desk. Theme in use is Socialize from Themeforest. Open links behaviour is set to open in new tab.

    Plugin Author Mark Zahra


    @bsthp thanks for the screenshots, but they’re missing the sidebar on the right where the link behaviour settings are. Can you please send us those?

    @machouinard could you contact us here with the details so our developers can take a closer look at what you’re doing to resolve this, please?

    Plugin Author Mark Zahra


    Thank you, @bsthp.

    We do have an update scheduled for next week that should fix this issue, version 4.14. If it does not fix it for you (after updating), please let us know.

    @markzahra) That’s great, Look forward to it. In the meantime, I have installed WP RSS Aggregator on a new Install of WP, running Theme 2019 on another website, with no other plugins. For some reason, Feeds are not being imported, even though, when in Feed Edit view, the last 5 Feed items are displaying in the Feed preview section. Any ideas what might be causing this and would you prefer I open a new Post for this issue?

    Plugin Author Mark Zahra


    I’ll reply to the other post about this here: https://wordpress.org/support/topic/no-feed-items-found-message/

    Plugin Author Mark Zahra


    Hey folks, can you please confirm whether the latest update has fixed this for you?

    Mark, hi! Deleted and reinstalled v4.1.4 and still same issue. Testing on a completely new install of WP (using 2019 theme) with no other plugins installed. Also used all the WP RSS default settings. Tried on a few other of my sites, with same results. For some reason, only one of my sites is able to get RSS Ag working. Settings in this site are identical to all the other sites!!

    Plugin Author Mark Zahra


    @bsthp which issues are persisting on all these sites exactly?

    Feeds are not importing i.e. I have tried another RSS Plugin and that has no issues with displaying the feeds. Getting a little frustrated with your plugin. There is nothing that should be affecting it i.e. WP RSS Agg is the only plugin on a one page, default wordpress installation. Have you checked at your end to confirm if server configurations may affect the plugin?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘OPen link in new browser window/tab’ is closed to new replies.