Support » Plugin: MyCryptoCheckout - Accept 95+ coins: Bitcoin, Ethereum, and more » “Open in wallet” button on checkout page

  • Resolved ssaltman@gmail.com

    (@ssaltmangmailcom)


    Below the QR code is a button that says “Open in Wallet”. This button does nothing. What is the expected behavior of this button?

    This is in a test installation in woocommerce.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have sent a payment. How does the plugin know the payment was received? I see in my trezor the payment was received. But the plugin is still “waiting”.

    Ok, sorry the repeated posts to this thread, I can separate if you want.

    Ok, it looks like the first BTC transaction was recognized by the plugin, because the number of free transactions went from 3->2. However, the related woocommerce order is still at status “pending payment” – will this be updated?

    Oh, now it says completed! It took about 30 minutes from transaction to completion. So just the first question – what is the button supposed to do?

    Plugin Author edward_plainview

    (@edward_plainview)

    BTC can take a long time to get a payment through. ETH is usually a much better (faster) choice for transactions.

    Regarding the link… depending on which wallet you use, it should automatically open with the payment info filled in.

    You use a Trezor hardware wallet, I take it? We haven’t tested MCC with that yet so we can’t say what exactly isn’t working.

    Ok, got it.

    Here’s a problem. I am testing and I sent a transaction through blockchain.com. The transaction is visible in my wallet but unconfirmed. This is after two hours. So the transaction cancelled.

    Can I extend the time beyond 2 hours? I’m thinking maybe 6 hours?

    Plugin Author edward_plainview

    (@edward_plainview)

    > Can I extend the time beyond 2 hours? I’m thinking maybe 6 hours?

    You can do that in the MCC payment gateway settings.

    I don’t actually see it under “account” or “global settings”. Can you let me know where it is?

    Also, the “Cryptocurrency exchange rates updated” value is 50006 years ago

    Thanks for replying so quickly.

    Plugin Author edward_plainview

    (@edward_plainview)

    Admin > WooCommerce > Settings > Payment gateways > MCC > Manage

    What timezone are you in?

    I’m in usa east coast time.

    Yes, found the setting for extending the cancelling timeout. Thanks.

    One more question, sorry for the many questions…

    How does the plugin differentiate between two transactions of the same exact value to the same wallet? Are the transactions tagged with an id? All of the products on my site are the same price.

    Plugin Author edward_plainview

    (@edward_plainview)

    > How does the plugin differentiate between two transactions of the same exact value to the same wallet?

    We have a system where the crypto account is slighty modified for each transaction. The modification is tiny and can barely even be measured in cents, but enough for us to detect the transaction.

    Very cool. Thanks.

    I can send you a screenshot of the display issue: but this is what the line says:

    Cryptocurrency exchange rates updated 50006 years ago

    Plugin Author edward_plainview

    (@edward_plainview)

    Fixing that bug right now…

    Just to clear up, I’m in east coast time, but the server time is UTC 0 I think.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.