• Resolved martinrtr

    (@martinrtr)


    Hi

    A few days back we noticed that the snippet for our blog posts appearing on our homepage were all the same.

    http://files.carrdale.com/qArgKKk

    It’s taken a while but we think we have tracked down the cuprit. Something called jetpack open graph tags. Looks like something that jetpack does without being asked and, so it turns out, without you having any control over what it serves as OGTs!

    We suspect that the problem arises from the fact that when we create a new post we simply duplicate an old one. It seems that the OGTs come with it – i.e. they don’t alter with new content. This is bad.

    My first question is then, is it actually possible to edit the tags? If not, my second question is – how do we fix this?

    Thanks
    Martin

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Karen Attfield

    (@wpkaren)

    Hi @martinrtr

    Jetpack does add Open Graph tags to posts if the Publicize and Sharing features are active, which I can see are active on your site. Jetpack adds these in order to share the correct content to social media.

    This shouldn’t normally affect excerpts on your site though, so if you’ve been able to narrow the issue down to those Open Graph tags it would seem that the way those tags interact with your site theme or any plugins that are helping to create the duplicated posts could be conflicting.

    If you aren’t using those features, I’d recommend disabling them. You can disable Publicize and Sharing features via Jetpack > Settings > Sharing from your WP Admin dashboard.

    If this isn’t working for any reason, you can also disable the Jetpack Open Graph tags with the following code snippet, which can be added via a plugin such as Code Snippets:

    add_filter( 'jetpack_enable_open_graph', '__return_false', 99 );

    If for any reason this doesn’t work, could you let us know if the issue remains after duplicating a post with Jetpack deactivated?

    Thread Starter martinrtr

    (@martinrtr)

    Hi Karen – thanks for coming back to me.

    As it happens the problem was nothing to do with OGTs – despite me blaming them! It suddenly dawned on me that the duplicate ‘snippets’ were actually the post excerpts. Under screen options you can toggle excerpts on / off (tnhough why you would want this function heaven only knows!). In this case they had been switched off so blog editors weren’t seeing them and not creating new ones. All fixed now.

    Martin

    Plugin Contributor Dan

    (@drawmyface)

    Hi Martin

    Thanks for confirming that! Let us know if you need anything else.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.