Support » Plugin: Yoast SEO » Open Graph problems since one week aprox

  • Resolved caparros07

    (@caparros07)


    Hi! Until one week ago aproximatly, everthing went good with social shareing.

    Firstly i want to congratulation for the team for this awesome plugin.

    I only use Facebook shareing, so didn´t try Twitter and others. Im using the Facebook APP id wich i use for login with Facebook.

    The point is that when i create a new blog´s post, i wait until another plugin optimizes the image and after that i share the post in my fan page, but i can´t see the image, sometimes neither the title and description, and i see the error that i must specify the OG:image etc…

    What i do for now to fix it is: i edit the post, go to featured image and edit it (crop a little bit the height). Then i save and update the post, that fix it, but it´s so tedious because i´m not the editor, i just made the web, so my coustomer is calling me every time.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    Thank you for your email and your kind words. We’re glad to hear you’re enjoying the plugin.

    We understand that when you share a URL on Facebook the image, title and meta descriptions do not always show.

    – Can you confirm you’re using Yoast SEO version 9.6.0? Does updating resolve the issue?
    – Are all your plugins up-to-date? If not, please update them.
    – Does the issue occur when you deactivate the other plugin which optimizes your images?
    – Can you share some examples of URLs you’re having this issue with?

    We look forward to your response.

    Hello,

    Yeah i had also this issue and i reverted back to old version of Yoast and it’s only the solution. It seems not fixed in recent few updates.

    Hi!

    Thanks for your answers. Yes i have everithing updated. The only thing that “solved” this issue was deactivating the plugin wich optimizes the images. Is not a complete solution because many times i have to force the link to be fetched from Facebook debugger tool, but in the first try it works. Before deactivating this plugin, i had to resize the images.

    I don’t have now a link with the problem, when my customer reports me the issue again i’m going to leave one post without fix and put the link here.

    After your revision, i’m going to downgrade Yoast to try what Urnabold says, thank you for the info! So if it works normal again, i save space on disk and my web runs faster.

    • This reply was modified 8 months, 3 weeks ago by caparros07.
    Plugin Support devnihil

    (@devnihil)

    If this issue only occurs when another plugin is also active that sounds like the issue is due to a plugin conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Check for conflicts.
    2. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    Same problem with Version 9.6.12 here.
    No og:image since 2 weeks.
    If i dump the post_id in class-opengraph-image.php in method: set_singular_image the id is always null.
    I use the normal thumbnail from wordpress – no custom field.

    If i set explicit an image under the post in Yoast Widget it’s the same.

    • This reply was modified 8 months, 3 weeks ago by Skrabbel.

    I can’t edit the post below. Sorry for duplicate post. I tried it on a clean WordPress, with standard theme and thumbnail-support. it’s the same.
    No og:image-tag in head. The other og-Tags are there. The twitter:image is also there.

    Plugin Support amboutwe

    (@amboutwe)

    @skrabbel If you have a similar issue, please open a new request. That way it’s easier to track issues and provide assistance. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Open Graph problems since one week aprox’ is closed to new replies.