Support » Plugin: Secure Downloads » Oops! That page can’t be found.

  • Hi There,

    Plugin installed perfectly.
    URL_path: Left blank
    Upload Folder: This has been changed
    Secret Key: This has been changed

    When i go to Files and upload a file, that seems to work fine
    However, when i go to Secure Link and either generate or email. The generated link and email link do not work. When clicking on the link it takes me to Oops! That page can’t be found.

    Example link: ?product=MjAsMTYzMjMyNTg2MyxnYXJ0aHN3ZXN0QGdtYWlsLmNvbSwwLjAuMC4wLCQyYSQxMiRaQWFvQnhWMUxKMTZ2Sy5MUE4zOGcuMGNTLzVxelkuTkZFLlNMRFRvb1JlQUkxTXZIbXd3Vw%3D%3D/IMG_20190101_001424-scaled.jpg

    Any help would be greatly appreciated
    Garth

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    1) Please recheck your error.log in your server configuration, about any relative errors. If you can not find error.log file, please contact support of your hosting company about helping in finding this file.

    2) Probably, its because of conflict with some other plugin or actual theme.
    Please try to deactivate one by one all your active plugins at the WordPress > Plugins menu and make testing after each plugin deactivation.
    If its not help, please deactivate all your plugins and active the default WordPress theme. And then retest it again.
    We just need to find the reason of this issue.

    Thank you!

    I have deactivated all plugins, including WooCommerce, only left Easy WP SMTP activated.
    I also changed the theme from Storefront to Twenty Nineteen.

    Added a new file and sent the secure link. Now it redirects to the home page of my site

    Any ideas?

    Garth

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    Configure the “ URL Path” at the settings, like “/get-download/“
    Kind Regards.

    Ok i have done that.
    I now get a 404 error: The requested URL was not found on this server.

    Do i need to manually create the URL Path folder?

    Kind regards,

    Update:

    If i manually create the URL Path folder.
    The link on the secure email take me to a blank Index of: listing page

    Kind regards,

    Just a further update. Reactivating WooCommerce now takes me to Oops! That page can’t be found.

    WooCommerce is a requirement for the site.

    Kind regards,

    Hi There,

    Any ideas on how to fix this?

    Kind regards

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    Please recheck your error.log in your server configuration, about any relative errors.
    There have to be description about the issue.
    It’s seems that somewhere in the configuration of the server blocking access to that file. May be you need to reconfigure or delete (be sure to backup it) the .htaccess file.
    You do not need to create such folders manually, it’s virtual configuration of folders at the Settings page.
    Kind Regards.

    I have checked the logs and there is absolutely nothing in them relating to the plugin

    Can i email you with URL details so that you can take a look?

    Plugin Author wpdevelop

    (@wpdevelop)

    Hello.
    You need to try to check your .htaccess file, and try ti reconfigure it. Check my previos email.
    You can also send screenshot of your settings configuration and link that does not work to info @ oplugins.com

    Thank you, Email sent

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.