Support » Plugin: Braintree for WooCommerce Payment Gateway » “Oops, something went wrong. Please try a different payment method.” error

  • Resolved dmpinder

    (@dmpinder)


    Hi, we’re getting a lot of failed Braintree payments on our WooCommerce store.

    We’re using:
    WordPress 5.7.1
    WooCommerce 5.2.0
    Braintree for WooCommerce Payment Gateway 2.5.0

    Screenshots: https://drive.google.com/drive/folders/1RPZpc_BCyqlBuJLHZkJGB4lWb18ItSo_?usp=sharing

    Whenever I try to pay with PayPal, the popup opens for me to login / register, I choose the card to pay with, and then I get brought back to WooCommerce with a warning at the top of the Checkout:

    Oops, something went wrong. Please try a different payment method.

    I only get the error above on Safari, if I use Firefox then I get a PayPal error inside the payment popup saying:

    Things don’t appear to be working at the moment.

    If I check the Console, there’s a lot of Braintree debug notices, including:

    [Log] Braintree (PayPal): Integration ready. (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Payment method tokenized. (wc-braintree.min.js, line 1)
    [Log] {nonce: "ef5f93bc-f534-08a3-f946-88345b76e902", details: Object, type: "PayPalAccount"} (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Payment error. The object can not be found here. (wc-braintree.min.js, line 1)
    [Log] NotFoundError: The object can not be found here. — jquery-1.12.4-wp.js:2 (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Creating client. (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Client ready. (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Creating integration. (wc-braintree.min.js, line 1)
    [Log] Braintree (PayPal): Integration ready. (wc-braintree.min.js, line 1)

    The Braintree Credit Card payment gateway works, but not the PayPal one, for any customers.

    Can you help?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi @dmpinder,

    Thanks for getting in touch about our Braintree plugin. I’m sorry that the PayPal portion isn’t working as expected! I’m happy to help out here 🙂

    It would be helpful to have a bit more information on what the communication with the payment provider looks like to troubleshoot this issue. Would you please send over a transaction log to us directly by contacting us here?

    https://www.skyverge.com/contact/

    Here are directions on how to get a log:

    1) Go to WooCommerce > Settings > Payments, select the gateway, and change the Debug Mode setting to “Save to Log”.
    2) Run another test transaction for PayPal
    3) Go to WooCommerce > Status > Logs and find the log from your transaction. Please note that the log may be in UTC/GMT time, so it may be offset by a few hours.
    4) Then, copy and paste the logfile into your response.

    Would you please let me know once you’ve had a chance to enable logging and have run another test? Please make sure to send it to us directly and not on the public forums since it’ll contain sensitive data.

    Thanks so much!
    Christine

    Thread Starter dmpinder

    (@dmpinder)

    Hi Christine,

    Thanks for the reply. I’ve submitted a ticket there with all the details from above, plus the debug log entry.

    It’s ticket 167571 in the help desk.

    If you could possibly prioritise it that would be hugely appreciated. I know it’s a free plugin and we’re in a queue, but we’ve already waited 24 hours with the ticket here too, so an expedited reply would be great!

    Thanks!

    Hi @dmpinder

    I found your email! I’m going to go ahead and set this thread to ‘resolved’ to close out the thread so we can focus on the email.

    Thanks,
    Christine

    Hello Christine, I just upgraded to the latest 2.6.0 and we are facing exactly the same issue described by @dmpinder [ 100% exactly the same! ]

    Our Paypal Log is showing only the data response encrypted [see below] – I even tried to debug the CURL function and it is not even reaching there.

    05-03-2021 @ 09:43:23 - Request
    environment: sandbox
    uri: generate
    data: Array
    (
        [merchantAccountId] => [hidden-for-security]
    )
    duration: 0.32087s
    
    05-03-2021 @ 09:43:23 - Response
    data: eyJ2ZXJzaW9uIjoy......

    [encrypted info]

    • This reply was modified 2 years, 4 months ago by uptopcorp.
    Thread Starter dmpinder

    (@dmpinder)

    Hey @uptopcorp,

    Christine helped us fix this over support ticket, but the issue was that we were running the Enable jQuery Migrate Helper plugin which was keeping the site on the legacy version of jQuery, not the most recent version. Once I disbaled this plugin (or changed its settings to use the most recent version) then the PayPal payments worked again.

    Christine confirmed a recent update to the SkyVerge plugin included an update to some JS library (I forget which) which likely caused this issue. As far as I know they haven’t released a further update which includes backwards compatibility.

    Hope that helps!

    Hi @dmpinder

    Thanks so much for your answer!

    Yes, it seems that was the issue for us too. We are in the process of upgrading to the latest WordPress and rewrite our other code using the legacy version.

    You have a wonderful day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Oops, something went wrong. Please try a different payment method.” error’ is closed to new replies.