Support » Fixing WordPress » Ooops POP3 connect: Error [65] [No route to host]

  • When I run the wp-mail.php, I get the following error: ‘Ooops POP3 connect: Error [65] [No route to host]’.

    Are there any settings somewhere that I need to change to get the blogging by email to work? It’s not working now, even though I have tried several pop accounts and checked the settings to make sure all the info is right.

    I’ve searched everywhere and found nothing but the same problem posted on this forum 1 year ago and no reply to it.

    Can anyone help?


Viewing 9 replies - 1 through 9 (of 9 total)
  • Les Bessant


    keeper of the Tiggers

    “No route to host” suggests that the web server can’t connect to the mail server. Assuming the server name is correct, I’d say you need to ask your host about it. Their firewall may be preventing POP3 connections from the sever to the outside world.

    I e-mailed Netfirms support (wich is the company that hosts my blog) and they did not answer my question about this. It seams like every time you contact customer sevice (and I’m talking CS from any company, not only Netfirms) they only read the first lines of your e-mail and then give you an answer from their FAQs wich you already read and didn’t help fix your problem.

    I set up an e-mail account from their control panel that is supposed to offer pop access. If I use a pop client to access the account, I can see the messages there, so I’m sure the account is working. But after setting up the blog by e-mail option in WordPress with the right account info, and loading wp-mail.php, I keep on getting the same error message: ‘Ooops POP3 connect: Error [65] [No route to host]’.

    I tried using a different pop e-mail account from my ISP and changing the settings in WordPress but it still doesn’t work. I get the same error message.

    I’m wondering, if I can access the e-mail account from within my pop e-mail client, how come I can’t access it using wp-mail.php. It seems like the coding on this php page is the problem, and if it’s not, then does anyone know of a free e-mail account that offers pop access and works with the post by e-mail feature in WordPress?


    Also, my pretty permalinks don’t work. They show on the status bar, but when I click on them all I get is the same index.php page. I tryed everything. I read the permalinks info on WordPress documentation pages and pretty much all the support questions in this forum and nothing. The weird thing is that I also have Joomla! installed in my account and configured to use pretty permalinks and it works, so it seems like Netfirms does support mod_rewrite and all that. I know my server is an Apache server and .htaccess is enabled but WordPress permalinks still don’t work.

    Something weird also is that even though chmod for .htaccess is set to 666 and this file is in the right folder, when I update the permalinks structure the .htaccess file is updated (meaning the modified date and time change and WordPress tells me it was updated), but the .htaccess file looks the same:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /folder/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /folder/index.php [L]

    # END WordPress

    And Netfirms support says they do support mod_rewrite with the following directives:


    What gives? Any help would be greatly appreciated.


    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I’m wondering, if I can access the e-mail account from within my pop e-mail client, how come I can’t access it using wp-mail.php.

    Your pop e-mail client is running on your computer.
    wp-mail.php is running on the server of your host.

    The host may not be configured to allow this sort of thing. In which case there’s nothing you can do about it except to work through them.

    The php code is fine. Your host is not.

    I run a wordpress blog on netfirms at I am suffering from the same email posting issue.

    BTW Juanfer i got working permalinks heres the .htaccess i used:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    I have the same problem with Netfirms. Love to know if anyone has a solution!

    Re the permalinks I had the same problem but managed to fix it. The problem wasnt in the .htaccess file but in the permalink structure. I updated the default with the following:

    Now it works fine. Seems Netfirms at least needs the index.php to precede the rest of the structure.

    I’m a Netfirms user and have the same issue as well. I installed wordpress by hand with the zip file. Anybody who used the control panel applications link have this problem?

    Thanks tigynet for the permalink tip. Worked perfect!

    Count me in as another Netfirms user with the same pop3 problem. Running WordPress 2.1.

    I emailed Netfirms about it, and here’s what they had to say:

    “Access to POP mail is only available via a mail client. You cannot access your pop account through the use of a script.

    At the moment, we do not offer this feature. There is no other alternative at this time. It has been added to our list of client requested features and may be included in a future service upgrade. Thank-you for your suggestion.”

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Ooops POP3 connect: Error [65] [No route to host]’ is closed to new replies.