WordPress.org

Forums

[closed] Connection lost. Saving has been disabled until you’re reconnected... (15 posts)

  1. rob_teamworks
    Member
    Posted 1 year ago #

    I'm getting the following message when updating posts in version 3.8.1:

    “Connection lost. Saving has been disabled until you're reconnected. We're backing up this post in your browser, just in case.”

    Not to mention that the whole admin area is running extremely slow. Even trying to deactivate plugins takes forever!

    I've tried the following:

    1) Disabled all plugins, removed plugins folder entirely - problem still persists.
    2) Removed the .htaccess file - problem still persists.
    3) Tried a fresh install - problem still persists.
    4) Cleared browser cache.
    5) Checked the server for any auto updates - there haven't been any.
    6) Changed the autosave to various times (define( 'AUTOSAVE_INTERVAL', 160 ); // Seconds), still same problem.

    Just to note - I'm not hosted on Go Daddy like a lot of the people with the same problem.

    This is the first site this has happened on, we run hundreds of sites but this is the only one on 3.8.1.

    Does anyone have any other suggestions? It feels like I've tried everything!

  2. JumboClicks
    Member
    Posted 1 year ago #

    strange i have not seen this problem yet

    could be a problem with your cookie

  3. rob_teamworks
    Member
    Posted 1 year ago #

    I've cleared my cookies as well but no luck. There's obviously a combination of factors that are contributing to this.

  4. The Grey Parrots
    Member
    Posted 1 year ago #

    Can you kindly enable dubug log, it that shows any error.

  5. rob_teamworks
    Member
    Posted 1 year ago #

    I've disabled and deleted all plugins but get this error:

    PHP Notice: wpdb::escape is deprecated since version 3.6! Use wpdb::prepare() or esc_sql() instead. in /home/teamwork/public_html/clients/ciw/wp-includes/functions.php on line 2908

    So that's a core problem, how can I fix it because it relates to this piece of code:

    function _deprecated_function( $function, $version, $replacement = null ) {
    
    	do_action( 'deprecated_function_run', $function, $replacement, $version );
    
    	// Allow plugin to filter the output error trigger
    	if ( WP_DEBUG && apply_filters( 'deprecated_function_trigger_error', true ) ) {
    		if ( function_exists( '__' ) ) {
    			if ( ! is_null( $replacement ) )
    				trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );
    			else
    				trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s with no alternative available.'), $function, $version ) );
    		} else {
    			if ( ! is_null( $replacement ) )
    				trigger_error( sprintf( '%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.', $function, $version, $replacement ) );
    			else
    				trigger_error( sprintf( '%1$s is <strong>deprecated</strong> since version %2$s with no alternative available.', $function, $version ) );
    		}
    	}
    }

    Specifically this line:

    trigger_error( sprintf( __('%1$s is <strong>deprecated</strong> since version %2$s! Use %3$s instead.'), $function, $version, $replacement ) );
  6. The Grey Parrots
    Member
    Posted 1 year ago #

    Why you using deprecated function?

  7. rob_teamworks
    Member
    Posted 1 year ago #

    It's not in my own functions.php file in my theme, it's the functions.php file within wp-includes... so not my choice!

  8. The Grey Parrots
    Member
    Posted 1 year ago #

    Can you kindly force upgrade your WordPress

  9. rob_teamworks
    Member
    Posted 1 year ago #

    It's the latest version as mentioned in the question.

  10. The Grey Parrots
    Member
    Posted 1 year ago #

    That's why I suggested force reinstall.

  11. rob_teamworks
    Member
    Posted 1 year ago #

    Again, I've already done that, point 3 in question.

  12. gomerblog
    Member
    Posted 1 year ago #

    No luck? This is happening with me as well 3.9 did not fix it. Seems to have many people not just on godaddy.com. I disabled my wp-cron and have just my server run cron jobs. could this be the problem?

    There is no functional issue just the annoying red error. Seen on multiple computers and browsers

  13. SiteSubscribe
    Member
    Posted 1 year ago #

    I've had similar issues on my VPS, been struggling with connection issues for days.

    I spoke with Google support, they verified that Chrome Version 34.0.1847.131 has known bugs on all devices (connection issues), update coming.

    It isn't totally solved but I've had far better results recently (so far) using Firefox 2.9.

    I'm still getting the connection lost notifications, but less frequently.

  14. gregg_strnr
    Member
    Posted 11 months ago #

    I have WordPress sites on 6 different hosting services and it is only happening on Host Gator. It continues to happen to all of my sites on Host Gator even when I deactivate all plugins and re-install WordPress.

  15. esmi
    Forum Moderator
    Posted 11 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this 2 month old topic as it references an older version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic