WordPress.org

Forums

TinyMCE Advanced
Onmouseover i onmouseout (10 posts)

  1. TTBoS
    Member
    Posted 1 year ago #

    Hello,

    After upgrading to WP 3.9 and TinyMCE Advanced 4.0, I noticed that when editing the article automatically removes me onmouseover and onmouseout variables of the images and when it is inserted and removed them anyway, and sets one image.

    It is a bug or something changed? how to set the WP to now when you hover your mouse on the image display to another?

    Ps2. Sorry for my english ;p.

    https://wordpress.org/plugins/tinymce-advanced/

  2. TTBoS
    Member
    Posted 1 year ago #

    Ps3. button "Edit Image" dont work when it is added to the bar did not even show for it when writing an article or news.

  3. johnzeiger
    Member
    Posted 1 year ago #

    I'm having the same issue - onmouseover and onmouseout are being removed

  4. johnzeiger
    Member
    Posted 1 year ago #

    Looks like it's a WordPress 3.9 issue.

    I restored my site from backup, updated WordPress to 3.9 and left TinyMCE Advanced at version 3.5.9.1 and am still having the issue.

  5. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    This doesn't seem related to TinyMCE Advanced. he same happens with the plugin deactivated. Looks like a change in TinyMCE 4.0.

  6. TTBoS
    Member
    Posted 1 year ago #

    So the fault lies with the TinyMCE 4.0 but unfortunately I'm not some mega webmaster and do not know how to fix it so maybe someone knows the page where you can report or to someone it improved? or write to the persons responsible for TinyMCE 4.0 to fix it?

  7. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    I've reported it to the TinyMCE developers.

  8. erxino
    Member
    Posted 1 year ago #

    Here you have one more with the same problem

  9. TTBoS
    Member
    Posted 1 year ago #

    Okay but what the "Edit Image" button? because he is the TinyMCE Advanced and when you add it to the bar in general is not displayed when writing articles or news.?

    In http://www.tinymce.com/tryit/full.php the button works properly, etc.

  10. erxino
    Member
    Posted 1 year ago #

    The problem occurs when you change to "view mode".
    If you make changes on the html text mode, and then, update, it works.
    But, in the moment you change the mode, you loose all changes realted with "onmouseout/onmouseover..."

    Any idea?

    Have we lost this option on pages?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic