WordPress.org

Support

Support » Plugins and Hacks » [Resolved] only works when editing my site

[Resolved] only works when editing my site

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Max Bond

    @max-bond

    Hello!

    Check plugin settings page (Appearance -> Fixed Widget Option)
    Did you enable “Enable plugin for logged in users only” option?

    doesn’t seem to make any difference either way. I have tried multiple settings. WHat to do?

    I am using it with a widget called “image widget” if that matters

    Plugin Author Max Bond

    @max-bond

    I cannot open your site. The link is broken.
    Check javascript console when you are not logged in.
    Do you see javascript errors?

    http://investment-help.org/
    im not sure how to check my javascript console

    Plugin Author Max Bond

    @max-bond

    Ok!
    Try to clear/disable cache plugins (WP Super Cache, Autoptimize).

    disabled both plugins, no effect

    Plugin Author Max Bond

    @max-bond

    I see it is working )

    yes I disabled all the plugins & it started working then turned them on one by one, seems to be ok now, thanks for the feedback, great plugin!

    Hi guys;
    I’m the Autoptimize developer. If Q2W3 Fixed Widget depends on jQuery and/or if it requires to be loaded early on (from <head>), then you might want to configure Autoptimize to exclude it (and jQuery, if it depends on it) from being aggregated/ minified in the Autoptimize settings-page.

    Have a great weekend,
    frank

    Futta,
    if you are suggesting Autoptimize may conflict with Q2W3 fixed widget
    I would like to know exactly how to set up Autooptimize to avoid this
    could you be more specific on how to set this up?

    As Autoptimize is active and all is working, there is no conflict? 🙂

    But for reference, if there would be; you would have to add “q2w3-fixed-widget.min.js, jquery.js” to the list of JavaScript to be excluded from optimization on the Autoptimize settings screen (advanced options).

    frank

    There does appear to be a conflict with Autooptimize, q2w3 works fine when I deactivate Autoptimize. I tried adding “q2w3-fixed-widget.min.js, jquery.js” to the exclude javascript list but that didnt seem to work

    in that case jquery might have to be jquery.min.js or jquery-min.js (depends on your theme).

    alternatives: run autoptimize without js optimization or possibly set the “force javascript in head-option.

    Plugin Author Max Bond

    @max-bond

    futtta!

    There is not direct conflict of Fixed WIdget and Autoptimize!
    When Autoptimize enabled (http://investment-help.org/), there is javascript error:
    Uncaught ReferenceError: a is not defined autoptimize_ca8259c4ed947e969210eb269640373f.js:71
    which affects all jQuery depended plugins.

    Looks like this error corresponds to copyright protection plugin, but I am not 100% sure

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] only works when editing my site’ is closed to new replies.