Support » Plugin: WordPress Popular Posts » Only working when logged in

  • Resolved metaglyphics

    (@metaglyphics)


    My widget is missing when I visit the site as a guest. But when I log into WordPress, it is there, and it renders properly.

    Any ideas why it might not be appearing for guests?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @metaglyphics,

    Hard to say without more details. If I had to guess I’d say it’s probably a caching issue? Are you using a caching plugin on your website?

    Thread Starter metaglyphics

    (@metaglyphics)

    No caching plugin, though WP Engine does do some server-side.

    It was working until recently, which is what’s odd.

    Thread Starter metaglyphics

    (@metaglyphics)

    Curiously, the Title from the widget appears, but no content.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Alright, please try clearing WPEngine’s cache (WP Dashboard > WPEngine > General Settings > Purge All Caches) and see if that fixes the problem. If it doesn’t then please share your site’s URL and I’ll have look for you.

    Thread Starter metaglyphics

    (@metaglyphics)

    That was the first thing I tried…

    Here’s the URL:
    https://live.icg600.com/

    I inspected the code, and when logged in, below the widget title I see some comments about the module:

    <!– cached –>
    <!– WordPress Popular Posts –>

    Followed by the widget, beginning with:
    <ul class=”wpp-list wpp-list-with-thumbnails”>

    But when not logged in, after the widget title, I only get:
    <div class=”wpp-widget-placeholder” data-widget-id=”wpp-4″></div>

    Thread Starter metaglyphics

    (@metaglyphics)

    Might we need to exclude something from the CDN?

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Yeah, that placeholder is supposed to be replaced by the actual widget on page load via JS. It’s not happening because something (a plugin must likely) attempting to minify WPP’s scripts.

    This issue was discussed recently here. I left a comment there with a workaround so please give that a try and report back your results.

    Thread Starter metaglyphics

    (@metaglyphics)

    That did it! Thanks for the quick response.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Don’t mention it, glad I could help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Only working when logged in’ is closed to new replies.