Support » Plugin: Cache Enabler - WordPress Cache » Only working on homepage

  • Resolved travis loc

    (@travis-loc)


    Hi,

    Looking for the message Cache Enabler by KeyCDN @ 02.06.2017 21:23:18, I can only see Cache Enabler working on my homepage https://gaiaretreat.com.au. I’ve got Cache Enabler working fine on another woocommerce site using the same webhost but running php 5.6. The only difference I can see is that this account is running php 5.4.45 Any idea what’s going on?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Do you still have Cache Enabler enabled for that site? I just checked it but do not see the “Cache Enabler by KeyCDN” comment in your home page’s HTML.

    Thanks for the reply. I didn’t realise yesterday but it now seems that cache enabler doesn’t work at all if I have cloudflare active. Yesterday I had cloudflare in development mode and that’s when I could see cache enabler working on just the homepage. I’ve just put cloudflare back in development mode so it will stay like that for 3 hours and again I can only see cache enabler working on the homepage.

    Also, I made sure I had emptied the entire Couldflare cache and my browser cache after turning on cache enabler.

    Have you also tried disabling other plugins to verify whether or not there may be a conflict somewhere?

    Yes I did try that and I have tried again. I have a staging domain not running through cloudflare. https://staging.gaiaretreat.com.au/ I have disabled all plugins and using the default WP 2017 theme and still the same behaviour, eg homepage is fine but cache enabler not working on https://staging.gaiaretreat.com.au/day-spa/spa-packages/

    I’ve just realised it’s some code in my htaccess file, when I figure out what I’ll post here, many thanks.

    The developers before me left this code from a Drupal install in the htaccess:

    # Rewrite URLs of the form ‘x’ to the form ‘index.php?q=x’.
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !=/favicon.ico
    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Only working on homepage’ is closed to new replies.