Support » Plugin: Facebook Comments » Only working on Chrome not IE, Firefox, Opera or w/e

  • Resolved ImGustavo


    My plugin of “facebook comments” isn’t showing on Internet Explorer, Firefox, Opera, Safari… just only works and its showed with Chrome.

    I try a lot of things but nothing works… I read the tip of @alexmoss (the plugin author) on this topic:

    He says, adding this lines the plugin works..


    xmlns:og="" xmlns:fb=""
    So, the full HTML tag on my site is:
    <html xmlns="" dir="ltr" lang="en-US" xmlns:og="" xmlns:fb="">

    But my template is in HTML5 and i dont know who put that code in mine… Any can help me?

    My template is this:

    <!DOCTYPE html><!-- HTML 5 -->
    <html <?php language_attributes(); ?>>
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    	<title><?php bloginfo('name'); if(is_home() || is_front_page()) { echo ' - '; bloginfo('description'); } else { wp_title(); } ?></title>
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head(); ?>
    <body <?php body_class(); ?>>
    <div id="wrapper">

    Where have to put, or what have to change to put the lines of @alexmoss ?
    Any can help me please? 🙁

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey,

    The instructions are slightly more updated on the plugin homepage. Also, you may want to look closely at the instructions on the official page within

    Finally i can fix it! Thanks Alex…

    this is how I did it:

    The option Enable XFBML should have inserted the code. It is better to insert this manually straight after <body>. Here’s the code (remember to change YOUR APP ID to your app ID:

    <div id=”fb-root”></div>
    window.fbAsyncInit = function() {

    FB.init({appId: ‘your app id’, status: true, cookie: true,

    xfbml: true});
    (function() {

    var e = document.createElement(‘script’); e.async = true;

    e.src = document.location.protocol +



    thanks thanks thanks!


    What file do I add this code in? I dont see <body> in any of the plugin files! The plugin works on Chrome and Safari but not on Firefox, it shows but I am not able to add comment.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Only working on Chrome not IE, Firefox, Opera or w/e’ is closed to new replies.