Support » Plugin: Zeno Report Comments » Only visible when nested comments activated

  • Resolved catsfoto1se

    (@catsfoto1se)


    Hi (again)

    I discovered that I must activate the nested comment function in the settings to make this plug-in to work.

    However, I don’t want to have the “Enable threaded (nested) comments” activated.

    Is there any easy solutions to make it work anyway?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Marcel Pol

    (@mpol)

    Hi, thanks for the report.
    There is an update that now supports the link with unthreaded comments.

    The standard behaviour is to add the link to the comment_reply. With unthreaded comments it gets added to the content of the comment.

    Just updated it, but it added a | sign too see screenshot

    I’m also wondering if it’s possible to change that text?

    —-
    Report Comment

    The lines above the link would be a good “sign” , so the users can see that it’s not a part of the comment..

    Plugin Author Marcel Pol

    (@mpol)

    I understand the idea for the ‘—‘, but in the current code it is not possible. If the comment was already flagged or moderated, you would not see the report link, but you would see the ‘—‘. It would need a lot of refactoring for just this visible detail.

    About the ‘|’, it is not in the code for this plugin.
    Can you share the address of the website? It might be content in CSS for a ‘<br />’.

    Plugin Author Marcel Pol

    (@mpol)

    For changing the text, use this PHP code:

    function my_zeno_report_comments_flagging_link_text( $text ) {
        return 'Report Comment';
    }
    add_filter('zeno_report_comments_flagging_link_text', 'my_zeno_report_comments_flagging_link_text');

    The pipe appeared after I updated your plug-in.
    It vanished when I disabled it, and reappeared when I turned it on again..

    https://rainbowcats.org/testtesttesttest/

    • This reply was modified 1 year, 3 months ago by catsfoto1se.
    Plugin Author Marcel Pol

    (@mpol)

    I’m sorry, but I cannot see where it gets added by the plugin.
    It might be a plugin or theme that is doing it. I suspect elementor?

    The only way yo test that is disable plugisn and theme, and see what happens then. Then enable theme and plugins one by one, and see which plugin is doing it.

    Well, this was strange, before, I tested this plugin with nested on, the same issue..

    I tested to disable yellowpencil (css to comment form), the same result

    I do use elementor, but in the previous version, that only supported nested comments, there wasn’t any pipe..

    Solved it!

    It was actually a leftover from the old version, where it was necessary to change the functions.php.

    There was code in your help file that I added to the functions.

    // change link layout to have a pipe prepended
    add_filter( 'zeno_report_comments_flagging_link', 'adjust_flagging_link' );
    function adjust_flagging_link( $link ) {
        return ' | ' . $link;
    }

    That’s the bad guy, but when I removed the added code, it worked!

    Plugin Author Marcel Pol

    (@mpol)

    Ok, good you managed 🙂

    Just one more question, I can add the —- by changing line 716
    $text = __('----<br>Report comment', 'zeno-report-comments' );
    … Which is totally not necessary now when you told me how to change the text, forgot that.

    However, is it possible to have the report comment text to the right instead of the left?

    The php code to change the text, I assumed it was going in the functions.php, but that caused a 500error

    Plugin Author Marcel Pol

    (@mpol)

    This works for me (tested):

    function my_zeno_report_comments_flagging_link_text( $text ) {
    	$text = __('----<br>Report comment', 'zeno-report-comments' );
        return $text;
    }
    add_filter('zeno_report_comments_flagging_link_text', 'my_zeno_report_comments_flagging_link_text');
    Plugin Author Marcel Pol

    (@mpol)

    You could add this CSS for right.:

    .zeno-comments-report-link {
        float: right;
    }

    Well, actually you have right, again, my copy function must have missed something, or as we usually say, error 666, human behind keyboard.

    I must however say that you have done a great job, booth plugin and the support, thanks a lot!

    Thx a lot, again!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Only visible when nested comments activated’ is closed to new replies.