WordPress.org

Forums

[resolved] Only user(admin) can't edit/trash pages (4 posts)

  1. Micked23
    Member
    Posted 1 year ago #

    Hi guys,

    Let me start by saying this website is a great resource for me as a WordPress user, and I hope you can point me in the right direction.

    I recently moved a project of mine from one live domain to another. The prefixes I used were different so I had trouble accessing the admin part of the website, after troubleshooting and changing the prefix of my new database to match the right ones, I eventually used force-upgrade.php.

    This worked for me, and my website works, only I can't edit any pages. I've set all the right database values such as user_level and capabilities.

    However, I still can't edit any pages. I've also tried disabling all my plugins, switching to the default theme, creating a new admin user through SQL and also re-uploading a fresh folder of wp-admin and wp-includes.

    Those were all the options I could find on the web, does anybody have any other suggestions to fix my problem?

    Thanks in advance.

  2. Micked23
    Member
    Posted 1 year ago #

    Running the latest version of WordPress.

  3. Micked23
    Member
    Posted 1 year ago #

    Resolved, missed a table name within the options table in my database, had to change the prefixes which sets the permissions.

  4. Andrew
    Nuh uh moderator
    Posted 1 year ago #

    Nice work :)

Topic Closed

This topic has been closed to new replies.

About this Topic