Support » Plugin: WooCommerce Services » Only US support?

  • Resolved chrismyenglishgoals

    (@chrismyenglishgoals)


    So I just updated WooCommerce Services today and now I get the following errors:
    “WooCommerce Services requires that the currency is set to US Dollars.”
    “WooCommerce Services requires that the base country/region is the United States.”

    I am based in Europe with Euros. Does that mean this plugin is useless to me?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Follow.
    Same problem.

    Plugin Author Boro Sitnikovski

    (@bor0)

    This error is specific to printing labels, the remainder of the functionalities should still work. We will rephrase the wording.

    same problem and no way to just dismiss the notice

    hope for a quick fix

    Hi there,

    I understand there’s not a way to dismiss the notice, you can simply ignore them for now since it won’t affect how your store works in any way. There is a going on discussion among our developers on this: https://github.com/Automattic/woocommerce-services/issues/1820, you can follow the issue for any updates on the fix!

    Thank you for your reply. It wont affect how site works but will affect my other notices i get for reminders/schedules etc when these 2 get some space

    • This reply was modified 3 weeks, 2 days ago by .

    Boro, et al, I suggest you fix this right away. You’re wasting a lot of people’s time at the moment, as we have to drop everything to investigate the issue and (in my case) reassure clients that their sites are still working ok. <_<

    Plugin Author Chris

    (@cshultz88)

    Hi there,

    Thanks for reporting this! We just made a release to remove this notification. Updating to version 1.22.1 should resolve this.

    I just want to chime in and say that one of the reasons I decided to go with WooCommerce instead of Square was that Square did not allow me to have a USD-based store while I am a Canadian-located business. This is a requirement for my store since I am a marketplace and all my buyers and sellers do business in USD. If you look up the Square forums, there are plenty of businesses here in Canada in the same situation (and I bet in other countries too – as can be seen in the comments here).

    When I saw the notice from this plugin I completely freaked out and thought that WooCommerce was going in the same direction as Square. This would mean I would have to either migrate to yet another platform, or take the time (which I currently don’t have) to test some currency plugin and see if it works with WC, WCMp and all my other plugins.

    Please be nice and continue letting us have a store based in a different country than the store currency. This is 2019 and I find it appalling that these supposed “world wide web” platforms expect companies to run a business in the same currency as their location – like it’s 1987!

    Finally, I am relieved to know the notice was just for the shipping label (which doesn’t impact me since my sellers use their own external shipping process). I had actually reverted to the backup I had made before installing the update because of how much this would impact my business. Now I know I can make the update without worries! Phew! Thanks for clarifying!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.