Support » Plugin: Jetpack by WordPress.com » Only seeing 7 Extra Sidebar Widgets

  • Resolved npagazani

    (@npagazani)



    Hi,

    I’ve seen this lately on a few sites now that I’m building.

    It’s a bit frustrating as I’m looking for the MailChimp popup widget but it’s not showing up in the list of available widgets, along with a few others.

    At this moment, only 7 Sidebar widgets are available.
    The Extra Sidebar Widgets module is activated.

    I deactivated, uninstalled, and reinstalled Jetpack, but still nothing. The same 7 widgets.

    What am I missing?

    Thanks,
    Nick

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support lizkarkoski

    (@lizkarkoski)

    Hi Nick –

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    Here are two sites I just recently built for clients, neither gives me the full list of widgets.
    https://karensworld-writer.co.uk/
    https://seekingthespanishsun.com/

    I’d like to have the mailchimp pop-up, though I got it to work in a text box, and also GDPR, and few others as well.

    On one of my own sites, like https://www.islandjobs.net/, it works just fine, all the widgets are there.

    Thanks.

    Plugin Support lizkarkoski

    (@lizkarkoski)

    Can you please use Jetpack’s Debugger module to send us some more information about your site(s)?

    1. Go to the Jetpack page in your dashboard.
    2. Click on the Debug link appearing at the bottom of the page.
    3. Click the link that says “click here to contact Jetpack support.”
    4. Fill in the description box and your name and email address.
    5. Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.

    Thanks!

    npagazani

    (@npagazani)

    OK, I’ve had my assistant send that off from one of our clients sites.

    Another interesting note. On all older installations, but still running the latest Jetpack version, the “Modules” menu item doesn’t appear in the WP dashboard. And on all of these installs, all widgets appear.

    On all the newer installations, I’m guessing the last couple of months, when the widgets started disappearing, the “Modules” menu item is shown in WP Dashboard. I can’t understand how the same version of the plugin (latest), installed on the same version of wordpress (latest) can show different menu items in the dashboard. ie some show “Modules”, and some don’t.

    Plugin Contributor Stef

    (@erania-pinnera)

    Hi there, thanks for sending over the info through our private contact form. One of our team member will look at it as soon as possible 🙂
    We’re working on a backlog of support requests at this time, and we generally answer in the order received, apologies in advance for any additional waiting!

    Thanks for for reporting the Module changes you noticed – I’m not sure I got it completely though. Has your assistant mentioned this as well in their message to us? It’d be interesting to add this note too.

    I’ve got an update and a resolution to this issue.

    It seems the theme is the culprit here, well at least one of it’s support plugins.

    The sites where this issue is occurring are all running pipdig themes which requires the use of their own “p3” plugin to control many of the theme functions. Upon deactivation of the plugin, the widgets re-appear.

    So I reached out to pipdig and they confirmed the plugin does indeed intentionally block the widgets.

    Here’s the response:

    It is indeed intentional as we deactivate any modules which aren’t needed or overlap with features in the p3 plugin. It’s safe to re-enable them though if you want to. To do that, you just need to add “?p3_jetpack_override” to the end of the admin url. For example example.com/wp-admin/?p3_jetpack_override. After doing that once, all the Jetpack features will be re-activated.

    Plugin Support pmciano

    (@pmciano)

    @npagazani

    We’re glad you were able to find the source of this issue, and thank you for sharing your findings!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.