Support » Plugin: WooCommerce » Only one product showing after update

  • Resolved LauraHartwigDesign

    (@laurahartwigdesign)


    I just moved my site, and during the move, woo got updated from 3.4.5 to 3.5.4. The site also got updated to the latest version of WordPress. On the new site, only one product is showing although there should be 59 showing like on the original site: http://girlagain.com/shop/ . All the products are showing in the back end. The visibility is set to store and search. The products are published and in stock. I’m not sure why the rest of the products are not showing. Can you help? Thanks!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Phil

    (@fullysupportedphil)

    Automattic Happiness Engineer

    @laurahartwigdesign since you migrated your site, you may be experiencing some corrupted data. The update could have also triggered some conflicts from third-party themes or plugins that aren’t compatible with the new WooCommerce version that you’re running.

    First thing to check is to open a product for edit. Make a change to the product and save your changes. Once you have, check to see if this is now available on the frontend of your site.

    If it is, then you can use the bulk edit tool to re-save your products.

    If that doesn’t help, try changing your permalink settings temporarily. Save the changes, then change back to how you had it previously.

    The last thing to test would be for conflicts. We have a guide on how to test for conflicts here:
    https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

    I hope one of those steps helps!

    Plugin Support Luminus

    (@luminus)

    Automattic Happiness Engineer

    Hi @laurahartwigdesign,

    We haven’t heard back from you in a while, so I’m going to mark this thread as resolved.

    If you have any further questions, you can go ahead and start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Only one product showing after update’ is closed to new replies.