Support » Fixing WordPress » Only one post is showing

  • Hello fellow wordpressers!

    I’m working on a new theme and somehow only one blogpost is showing. I have no widgets or plugins installed so no need to ask me to deactivate them.

    here’s the post code

    <div id="blogg_"
        <?php if (have_posts()) : ?>
    	<?php while (have_posts()) : the_post(); ?>
    
            <div <?php post_class() ?>>
            	<h2><a>"><?php the_title(); ?></a></h2>
    
    				<?php if ( has_post_thumbnail() ) : ?>
    				<div class"post_thumb">
                		<a>"><?php the_post_thumbnail(); ?></a>
                	</div><!-- post_thumb -->
                	<?php endif; ?>
    
                    <?php the_content(''); ?>
    					<ul class="meta"> 
    
    <li><?php the_time('F jS, Y') ?></li>
    <li>Posted in <?php the_category(', ') ?></li>
    <li><?php comment_number('No Comments','1 Comment','% Comments'); ?></li>
    					<!-- meta -->
    	</div><!-- post_class -->
    
                    <?php endwhile; ?>
    
                	<div class="pagination">
    
    <ul>
                        	<li class="order"><?php next_post_link('Older') ?>
                            <li class="newer"><?php previous_post_link('Newer') ?>
                        </ul>
                    </div> <!-- pagination -->
    
                    <?php else : ?>
    
                    	<h2>Nothing Found</h2>
                        <p>What you're looking for does not excist.</p>
                        <p>Return to <a>">Homepage</a></p>
    
                    <?php endif; ?>
    
    </div><!-- blogg_ -->

    I followed a new tutorial, and somehow somewhere things went wrong. Any ideas?

  • The topic ‘Only one post is showing’ is closed to new replies.