WordPress.org

Ready to get started?Download WordPress

Forums

Only one post displaying on blog (3 posts)

  1. spencercarli
    Member
    Posted 1 year ago #

    I've got a site I've been working on for a client and am running across a problem that I simply cannot figure out.

    Basically there are multiple blog posts published but only the most recent one is displaying. I've determined it's nothing with the plugins on the site.

    An interesting piece of info... I've got the site running under my personal site as well (where I did live dev work) and everything works fine, all blog posts display and so do comments and navigation. This isn't the case with the live site.

    However when I look at the twenty twelve theme itself all the posts display.

    Here are the links, any and all help is greatly appreciated. I'm totally stumped. This site is a twenty twelve child theme

    Working site: spencercarli.com/MikeClum/blog
    Non working site: mikeclum.com/blog-2

  2. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Don't know if it's related but this error comes up on that page when trying to validate it:

    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.mikeclum.com%2Fblog-2%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

  3. spencercarli
    Member
    Posted 1 year ago #

    Hmmm very interesting. I'll have to look into this more, any idea why this might be happening? Every other page validates (with errors though) except for this one.

    Thanks for checking this out! Wouldn't have thought to validate it.

Topic Closed

This topic has been closed to new replies.

About this Topic