Support » Plugin: WooCommerce » Only one of my shipping methods is appearing in shop

  • Resolved katherinemasters

    (@katherinemasters)


    Hi,

    For some reason only the first shipping method (from four shipping methods I’ve created in my Storefront website) appear on my product pages. Links to images attached of my woocommerce shipping pages attached. I’ve looked everywhere to see if there is something I should have selected to enable having all the shipping methods available on each product page.

    Not sure what I’m missing here but it is probably obvious. Any help us appreciated.

    https://pasteboard.co/InFjepr.png

    https://pasteboard.co/InFjqkW.png

    Thanks for reading,

    Katherine

Viewing 3 replies - 1 through 3 (of 3 total)
  • You have probably set the “Default customer location” to “Shop base address” on the WooCommerce > Settings > General tab?

    So that’s where WooCommerce thinks the customer is located. WC will only show the user those shipping methods which are available to him.

    If the customer enters a different location on the calculate shipping or on the checkout shipping section, WooCommerce will review the shipping accordingly. If at that time, more than one shipping method applies, the user should see a radio button choice.

    I think your options are:
    – Put up a note saying that shipping options and costs will be shown after the user has entered his address.
    – Set “Default customer location” to “Geolocate”. Geolocate relies on the user’s ISP location so its likely to get the country right but it may have difficulty correctly distinguishing different parts of the same city.
    – You can use a content block:
    https://en-gb.wordpress.org/plugins/custom-post-widget/
    make a content block to describe your shipping options and costs and use the block’s shortcode on every product page. If you update your shipping parameters you’ll need to remember to update the content block.

    Plugin Support rohittm

    (@rohittm)

    Hi there,

    This seems to be an issue with the priority of how shipping zones are configured. In the screenshots, you have provided, it first checks for the country and then the postcodes. So, even if the user enters their address with any of the postcodes, it’ll validate the first shipping zone because the country will be checked first.

    I’ll recommend you to drag up the postcodes and let the postcode validation take place first. Here’s how you can do that: https://docs.woocommerce.com/document/setting-up-shipping-zones/#section-4

    I hope this helps.

    Dear Lorro and Rohittm,

    Thanks so much for the help, this should do it.

    Thanks!

    K

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.