Support » Plugin: WP Paint - WordPress Image Editor » only one instance of babel-polyfill is allowed

  • Resolved Wes Modes

    (@wmodes)


    Hello, just installed WP Paint. When I try to edit a image the WP Paint window loads but hangs at “Loading …”

    Looking at the console, I see:

    Uncaught Error: only one instance of babel-polyfill is allowed
        at Object.<anonymous> (mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1)
        at Object../node_modules/babel-polyfill/lib/index.js (mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1)
        at o (mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1)
        at Object.0 (mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1)
        at o (mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1)
        at mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
        at mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    (anonymous) @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    ./node_modules/babel-polyfill/lib/index.js @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    o @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    0 @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    o @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    (anonymous) @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    (anonymous) @ mini-paint.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1
    wp-paint-box.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1 Uncaught TypeError: Cannot read property 'load_modules' of undefined
        at wp-paint-box.min.js?ver=bf5d1dd1001074e96126dc9883ff71cd9477bfafdab31106:1

    Is there something I’m missing or likely conflicts?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter Wes Modes

    (@wmodes)

    It appears to be a conflict with the Conditional Blocks plugins. Is there any way to workaround this?

    Plugin Author Dev

    (@devadattas)

    @wmodes This issue has been resolved in the latest version deployed today (i.e. 0.4.0). Could you please check and confirm for us if it is resolved at your end?

    Thread Starter Wes Modes

    (@wmodes)

    This worked. Thank you for your quick response!

    Plugin Author Dev

    (@devadattas)

    Glad your issue is resolved. If you liked our plugin/support. Please do leave a positive review for the plugin.

    I have the same problem. Running 0.4.4 version 🙁

    Took all the other plugins off and did’nt work.

    https://www.jomcallister.co.uk/

    Plugin Author Dev

    (@devadattas)

    @dietredthunder Could you please clear your CDN cache (if any) and try again. The specific issue is already resolved as of version 0.4.0.

    CDN Cache. Is that the browser cache. ?

    Plugin Author Dev

    (@devadattas)

    Please try clearing both browser cache as well as the CDN cache if you are using something like CloudFlare.

    Just cleared the caches using a plugin WP Fastest Cache.

    Still dont want to play 🙁

    Plugin Author Dev

    (@devadattas)

    Could you please disable WP Fastest Cache and try? I think that it is definitely a cache related issue as we haven’t had this issue crop back since version 0.4.0.

    Hust tried that. Still to no avail 🙁

    PS I’m using Firefox.

    Plugin Author Dev

    (@devadattas)

    Could you try it on the latest version of Google Chrome once? Although WP-Paint fully supports the latest Firefox versions, it is best that we reduce the number of variables.

    Just tried Chrome 🙁 No Joy.

    Could it be a problem with my host ?

    Could advanced gutenburg be arsing it up ?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘only one instance of babel-polyfill is allowed’ is closed to new replies.