Support » Plugin: Advanced Ads – Ad Manager & AdSense » Only one ‘enable_page_level_ads’ allowed per pag

  • Resolved pixeo

    (@pixeo)


    Good day,

    I am getting the dreaded:

    “Only one ‘enable_page_level_ads’ allowed per page”

    I have read the solution here:

    https://wpadvancedads.com/only-one-enable-page-level-ads-allowed-per-page/

    To troubleshoot I disabled advanced ads and did a search on the source code for one of my pages to identify if there was somehow some lingering culprit at work. The only reference to google ads I can find is the code below:

    <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-#################","enable_page_level_ads":true,"tag_partner":"site_kit"});</script>

    This is from the Google Site Kit plugin. As this is a standard google product and does not display ads, but rather connects my page to my Googel Ads Account I figured you should know and am hopeful there is a fix.

    Thanks.

    Shawn

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Support henningaa

    (@henningaa)

    Hi Shawn,

    Thanks for reaching out.

    I suggest using either Site Kit or Advanced Ads to connect your AdSense account with WordPress. This ensures the line of code is only entered once.

    Using Advanced Ads here would bring the advantage of being able to import the ads directly and also a working implementation together with privacy and consensus solutions.

    Please let me know if you need anything else.

    Best regards,
    Henning

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.