Support » Installing WordPress » Only MySQL 3.23 available -> what next?

  • Hi everybody,

    My host only offers MySQL 3.23.
    Is there an earlier version of WordPress that it makes sense to run on that version of MySQL?

    Or would that mean so much trouble that it’s safer to get a new host?

    Thanks in advance for all advice.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    2.0.x still supports MySQL 3.23.23 as the low end. So you can get 2.0.8 from the release archive and it should work okay.

    But frankly, I’d switch hosts anyway, unless they have a more up to date version available.

    Thanks for your reply.
    However, I downloaded 2.0.8 – and got exactly the same error message as before:

    ERROR: WordPress 2.1 requires MySQL 4.0.0 or higher

    although I was using the 2.0.8 files.
    Do I have to delete anything first?

    EDIT: Well, let me answer my final question above … I hadn’t thought of the fact that my FTP program does not overwrite files which are newer than the other files. – So, in the meantime, I deleted the “old” 2.1 files, copied the 2.08 stuff onto the server and – it seems to work.
    Thanks again. 🙂

    You did something wrong. Consider deleting your wordpress files, get a new set of 2.0.8 files (see below) and redo the upload. 2.0.8 will install with a MySQL version as low as 3.23.23.

    Version archives:

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Only MySQL 3.23 available -> what next?’ is closed to new replies.