Thanks for your reply.
However, I downloaded 2.0.8 - and got exactly the same error message as before:
ERROR: WordPress 2.1 requires MySQL 4.0.0 or higher
although I was using the 2.0.8 files.
Do I have to delete anything first?
EDIT: Well, let me answer my final question above ... I hadn't thought of the fact that my FTP program does not overwrite files which are newer than the other files. - So, in the meantime, I deleted the "old" 2.1 files, copied the 2.08 stuff onto the server and - it seems to work.
Thanks again. :-)