Support » Plugin: WP-Live Chat by 3CX » Only my texts in the chat transcript & history

  • tzwick

    (@tzwick)


    Hello,

    I`m using the latest version of the plugin and the latest version of WordPress (5.3.2) along with PHP7.3 on a root box.

    Settings:
    Enable Manual Chat Initiation (true)
    Enable chat transcripts (true)
    Required Chat Box Fields: Name and email
    Send transcripts to: Admin
    3CX High Performance Cloud Servers (true)

    Problem:
    When I open the chat via manual chat initiation to a visitor, his name is “Guest” (Default visitor name) and there is no email ofc.. But when I send the transcript (to me), there are only my texts in the email and in the database (history), too.

    Update: it is the same when the visitor opens the chat box and enters his name & email.

    What can I do to get the chat transcript and history database-entry saved with the complete conversation? (The texts from the “Guest” and me).

    Thank you for your great plugin!
    Tom

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wp3cx

    (@wp3cx)

    Hi @tzwick ,

    Can you please provide the URL of your website?

    If you are not comfortable sharing it publicly, please try the following and get back to us:

    – Open your website’s front-end in incognito mode as well as the browser’s console (F12)
    – Initiate a chat
    – Check the console for any 401/403 errors

    Hi @wp3cx ,

    I`m sorry for my late reply. I opened the website in private mode and initiated a chat. There are no errors in the console.

    The website URL is https://scresign.de

    Plugin Author wp3cx

    (@wp3cx)

    Hi @tzwick ,

    While in a chat can you check your webserver’s logs for any PHP errors? (Especially related to sessions)

    Plugin Author wp3cx

    (@wp3cx)

    Hi @tzwick ,

    The live chat on your site is currently offline so I cannot further troubleshoot but do you by any chance have any WAF installed either on WordPress or the host? There’s a high chance new message requests are being blocked.

    Hello,

    I had chat right now where I initiated the chat. There is fail2ban and ModSecurity installed. But nothing related to the chat plugin in the logs.

    In the SSL/TLS Log (Apache Server):

    2020-01-16 19:46:19 Error 84.149.227.121 401 POST /wp-json/wp_live_chat_support/v1/end_session?nocache=1579200378455 HTTP/1.0

    In the php7.3 (FPM) error.log are warnings:

    [16-Jan-2020 19:46:29] WARNING: [pool scresign.de] child 31153 said into stderr: "NOTICE: PHP message: PHP Warning: Illegal string offset 'aid' in /var/www/vhosts/scresign.de/httpdocs/wp-content/plugins/wp-live-chat-support/functions.php on line 594"

    And earlier today without a chat:

    [16-Jan-2020 17:47:18] WARNING: [pool scresign.de] child 28990 said into stderr: "NOTICE: PHP message: wplc_return_chat_id_by_rel_or_id cannot find rel=BkTY-MRlI_1579192708997"

    Maybe this helps a bit.
    The “Guest” in the chat is named: “none:”. It worked today with the transcripts when another user entered his name and email.

    • This reply was modified 2 months, 3 weeks ago by tzwick.
    • This reply was modified 2 months, 3 weeks ago by tzwick.
    • This reply was modified 2 months, 3 weeks ago by tzwick.
    Plugin Author wordpress3cx

    (@wordpress3cx)

    Hello @tzwick, can you please disable modsecurity and try again? You should not get those 401 replies, nor PHP errors related to missing sessions.

    If you get it working without modsecurity, we need your modsecurity configuration so we can try to replicate your environment.

    Let us know!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.