Support » Fixing WordPress » Only my front page works- All my permalinks are 404

  • Resolved kpars


    Hi folks. I’m having a really, really weird problem.

    I’ve used WordPress for several years now just fine on a shared hosting account but I just bought a virtual dedicated server. I’ve forwarded my domain and moved all my WordPress files to the new server, including the WordPress MySQL database stuff (I used the BigDump utility to do a staggered import since my databases were too large otherwise).

    But now the only thing that works on my WordPress blog is the front page. For instance, if you try and click on the permalink to any of my posts, it just comes up with a 404. Try it yourself:

    I can access the WP-Admin pages and in the manage posts area I can edit posts and create new ones but then I click the “View” button next to them, it just brings me to the same 404.

    This is kind of freaking me out, so I really hope somebody here can help me out. Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same thing happened to me when I upgraded my test blog. It was htaccess related. I had renamed it during the upgrade and needed to go back and rename it to what it was before the upgrade.

    I’m having the same issue after the 2.5 upgrade. I usually upgrade manually but did it via the dreamhost one click upgrade… it made a copy of my old database but looks like it amended both htaccess files!

    Most definately a .htaccess problem with mod_rewrite in the case of I’d recheck the contents of hte .htaccess, the default config doesnt work on all servers either.

    My site is at and

    I managed to back the latter out to the older version but it did a database update and I lost all my pages to a 404 again.

    What are we looking for in the htaccess file?

    Thanks to dd32 my issue is resolved

    Sometimes, just accessing the .htaccess (Options > Reading) in the WP admin area and Updating the Permalinks structure will fix this.


    Just upgraded to 2.5 and got this problem. I have a copy of my entire previous WP installation but I can’t find or see the .htaccess, it’s a hidden file, apparently.

    Any tip on how to go about editing the .htaccess?



    You have to change .htaccess to htaccess.txt in order to edit it in a text editor, then change it back to before with the period in from and dropping the txt suffix.

    Thanks to all of you who responded.

    Yep, it turned out to be an .htaccess problem. I had one for the server in general but I had to create a new blank .htaccess file in the base directory containing all my WordPress stuff. I did this by creating a new text file and naming it .htaccess and adjusting the permissions on the file to be writeable globally so that WordPress can write on it.

    Hopefully this helps somebody later on who finds this post on Google.

    pebbleworm: often times FTP clients automatically hide the hidden files on your server just as Finder (Mac) or Explorer (PC) would on your home computer. There’s usually an option in your preferences or settings for the FTP client that will allow you to view hidden files.

    For instance, I was using a Mac FTP client called Transmit and I couldn’t see my .htaccess file until I enabled the “Show invisible files” option under the View menu.

    Hey guys, especially dd32 (as it looks by your blog ‘’ that you have resolved the issue you had before, which is the same thing I am dealing with now). I have been going CRAZY myself lately with this same kind of issue – i.e. problems with updating permalinks, trying to change my .htaccess file, etc, and I still can not view actual posts on my blog site, I’m really really frustrated now – if anyone can help, I would SO appreciate.

    Let me try to explain what happened so you could maybe better help me:

    1) First, I had an issue with one of those ‘500 – Internal Server Error’s (I had made a duplicate post that suddenly disallowed me to edit or delete any post). I managed to fix that issue by disabling and re-enabling/updating all of the plugins that I had set up for the blog (also I upgraded to WordPress 2.6.2).

    2) I also followed one user’s suggestion to change the permalink structure to the default, then I changed it back to the “Day and Name” permalink structure. This began the permalink problem.) Now I can not view any full post on my site:

    3) I will also note that all my blog files reside in the “” structure, but are viewable in the root folder – I still really think that this may have something to do with the problem

    4) Again, as I say, I tried to edit the contents of the .htaccess file / changing permissions of that file, etc, but this did still not resolve the problem.

    Also, I looked for what used to be the “update permalink” feature, but it looks as if they no longer have that in the latest (2.6.2) versions of the WordPress interface.

    Any help anyone can provide would be so greatly appreciated…

    Well this seems so crazy to me, but (maybe I kind of got this idea from reading someone else’s post), on the ‘Permalinks’ page, I changed the “Common Settings” from ‘Day and Name’ to ‘Custom Structure: /%year%/%monthnum%/%day%/%postname%/” and now all posts seem viewable under there names – so crazy, but just “Thank God” it works!

    Hope this can help anyone else struggling with this same difficult issue….

    good luck everyone, and keep the faith! 😉

    There is always a solution huh!!

    kpars can you share how you fixed it. I got the same problem with Bluehost.,

    I suppose I will post here as well. Having same problem with my site . if you right click open link in a new window it comes up with a 404 error, and if you click it normal it redirects to the recent posts page. Currently only the static assigned pages are working, recent posts and the perm static home page of portfolio.

    I cant even browse my portfolio, let alone have my clients browse it, i’m just so confused. Any one willing to help, I would greatly appreciate it. thank you.
    Jennifer Louise

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Only my front page works- All my permalinks are 404’ is closed to new replies.