Support » Plugin: Smart Variations Images for WooCommerce » only loading gif is showing, image not show

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Rosendo

    (@drosendo)

    Hello,

    You have errors in your javascript that is preventing load.
    In order to debug for incompatibility please try the following steps:

    1. Backup your site, I advise the usage of UpdraftPlus so that you can easily restore the DB to the previous state once discovered the issue.
    2. Deactivate all plugins, except WooCommerce and Smart Variations Images and test the system.
    3. If if works then start activating the other plugins one by one until the issue returns, that way you know what plugin is causing the issue (maybe plugin is not updated or not compatible with WooCommerce)
    4. Does your system have the minimum requirements?
    5. Please check the Common Errors.
    6. In extreme cases try changing the theme.

    Thanks,
    David

    • This reply was modified 3 years, 10 months ago by David Rosendo.
    • This reply was modified 3 years, 10 months ago by David Rosendo.

    Was there ever any solution for this? I am having the same problem, I have a product with no images added, with SVI activated it just shows a loading icon instead of the default image. Disabling SVI correctly shows the default image. However, with SVI enabled I noticed in the console there were javascript errors, so I began disabling all other plugins until I found the plugin causing the conflicting javascript errors. With that plugin disabled however, the errors went away from the console but the loading image still shows up, and the javascript still seems to not be working.

    With only WooCommerce, SVI, and Redux Framework plugins active I am still just seeing the loading image. Also, I am unable to add anything to the cart without seeing a “Please choose product options…” error even though I am selecting options. This is only happening if I have no images, once I upload them everything works fine.

    Plugin Author David Rosendo

    (@drosendo)

    The plugin expect to have an image, and for that reason the loading stays present(I guess I have to remove it if no images present :P).
    You can hide it via CSS: https://www.rosendo.pt/question/hide-loader-elements/

    Cheers,
    David

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘only loading gif is showing, image not show’ is closed to new replies.