Support » Plugin: Amazon AWS CDN » only images

Viewing 15 replies - 1 through 15 (of 33 total)
  • i can still see the images being loads from the local server and not from the cdn

    Plugin Author luckychingi

    (@luckychingi)

    Hello @saveatrain

    Did you clear the cache after making the changes?

    hi luckychingi,

    yes of course, and not only that.

    i went into amazon cloudfront, disabled, waited 15 min
    then did enable,
    went back to wp-optimize and cleared the cache.

    1. do you currently see the images being loaded from cloudfront or the local server? i couldn’t understand where they load from
    2. maybe you can download wp-optimize and see how is the reaction on your end

    Plugin Author luckychingi

    (@luckychingi)

    Thanks,

    Will install wp-optimize on my website and test.

    what’s your AWS Cloudfront domain?

    blog=www.saveatrain.com/blog/
    aws cloudfront link=d2hh3s9lc4ptlp.cloudfront.net

    i am now sure the cloudfront is not working for images, because i refreshed the amazon invoice and i don’t see any charge for the cloudfront, so it means its not servering.

    here is the plugin settings screenshot: https://ibb.co/mSQv77G

    Plugin Author luckychingi

    (@luckychingi)

    I dont know what the setup is for Savetrain, but when I tried to load an image from the site, the image did not load from CDN. I tested with an image from WPAdmin and it loaded the image from AWS CDN.

    Here’s the comparison
    SaveTrain
    https://cdn.wpadmin.ca/wp-content/uploads/2019/11/CDNST.jpg
    WPAdmin
    https://cdn.wpadmin.ca/wp-content/uploads/2019/11/CDNWP.jpg

    i didn’t fully understand this paragraph
    “I dont know what the setup is for Savetrain, but when I tried to load an image from the site, the image did not load from CDN. I tested with an image from WPAdmin and it loaded the image from AWS CDN.”

    what do you mean “when i tested from WPAdmin” ?

    Plugin Author luckychingi

    (@luckychingi)

    Here’s what I did

    I copied the following code into index.html file on my computer

    <img src='https://d2hh3s9lc4ptlp.cloudfront.net/wp-content/uploads/2019/10/points-of-interest-where-to-go-and-places-to-visit-in-the-netherlands-featured-1400x735.jpg'>
    
    <img src='https://d2e1hefq4yjysd.cloudfront.net/wp-content/uploads/2016/02/screenshot-1-1.jpg'>

    Once saved, I opened index.html file in chrome
    Opened developer console and reloaded the page to examine the headers

    the headers state that when the request is made to fetch the image from savetrain .com website, it gets redirected to the original website

    But when the request is made to fetch the image from wpadmin.ca website, its fetched from AWS.

    Which led to my statement, I dont know the setup for Savetrain.com. The image surely loada from AWS CDN.

    the images loads from the cdn, because indeed i have setup cloudfront and its deployed correctly.

    did you try to set wp-optimize alongside aws cdn plugin, and enable caching in the wp-optimize on your own site?

    Plugin Author luckychingi

    (@luckychingi)

    The headers dont seems to agree. Setting up CDN is one part, it being utilized correctly is the other

    I installed wp-optimize on my website and the images still load from AWS CDN.

    Currently, I dont have any website that is installed in a sub-folder. Will setup a demo site over the weekend and test.

    ok, just so you see what i did

    here is the amazon cdn plugin settings: https://ibb.co/mSQv77G
    and here is the cloudfront deploy confirmation: https://ibb.co/nsy5b6h

    what else do you want me to perhaps look at? htaccess? wpconfig?

    Plugin Author luckychingi

    (@luckychingi)

    I had already checked that 🙂

    Did you change something? the images dont redirect anymore

    https://cdn.wpadmin.ca/wp-content/uploads/2019/11/CDN1.jpg

    But the website still does not show the CDN URL 🙁

    please explain to me what you meant by “images don’t redirect”

    for me, from the beginning, they weren’t showing the cdn address nor i understand the term redirecting.

    i only flushed the cache.

    do you have an email? if so i will give you backend access if you want to take a look

    • This reply was modified 2 months, 2 weeks ago by saveatrain.

    i have an idea of the issue, tell me what do you think.

    with wp-optimize, you can set caching, but you can also set preload.

    do you think that if i disable both, then redeploy the cdn, and only after do the preload, will it understand that the images should load from the cdn.

    because basically what i think is happening is that your plugin works correctly, but the preload basically cache the files, and direct the image loading to the local server and not to the cdn.

Viewing 15 replies - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.