Support » Fixing WordPress » Only HTML, no VISUAL display of post after restore

  • marilynch


    Had tried a backup program for 1st time, then upgraded to 2.8.5. Lost data, the backup program apparently failed too, but my host, Network Solutions, was able to restore it w/their backup.

    All posts display fine on Web, and all but most recent (and longest and most important) post can be edited fine.

    The one exception is the most recent post (again, it’s longer than others, with more links too–which I mention in case that’s a clue to resolution). I need to revise/make additions to this post frequently, and I don’t like to work in HTML, prefer to use VISUAL tab.

    The VISUAL tab (and HTML tab) work fine for OTHER posts, and the HTML works fine for this post, but the VISUAL doesn’t work for this one.

    What displays instead of VISUAL? A blank screen with occasional red streaks through it. If I click HTML tab, then click back to VISUAL tab, the HTML displays on that screen (replacing that blank screen with red streaks).

    Also note that since this restore, the blank screen and red streaks show up under VISUAL tab for some of the other posts too–but only momentarily; they’re promptly replaced with the appropriate VISUAL display. Unfortunately, that never happens with this single, and most important, post.

    Help very much appreciated! I’m not super tech savvy, so please speak in layman’s language. Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.



    thanks for these ideas

    i only use the default theme, so guess it’s unlikely to be theme-related.

    however, as mentioned in 1st line of my posted question, i did add a new plug-in yesterday (wordpress online automated back-up–didn’t mention by name before because i’m not tech savvy and perhaps not a fault of the plug-in but a fault on my end).

    so, i’ll try your suggestions 1 and 3 above. thanks so much.

    For what it’s worth, I am having the same problem. I narrowd it down to the Plugin Link to Post

    I haven’t resolved it yet. At least I know the culprit, though.

    I have encountered this behavior many times since I initially wrote my first reply and I am still encountering it in v3.0. Luckily, I have found that in more cases than not, this behavior is caused by some extra white space at the end of the page/post.

    Specifically, try the following to work around this problem:

    1. Switch to the HTML tab
    2. Scroll down to the end your page/post. In my case, I encountered this behavior in pages.
    3. Most likely, you will find extra white space at the end. Erase this. Click on UPDATE.
    4. Click on the Visual tab. Everything should appear normally.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Only HTML, no VISUAL display of post after restore’ is closed to new replies.