WordPress.org

Forums

[resolved] Only home page loads (8 posts)

  1. supah
    Member
    Posted 1 year ago #

    Can anyone help me figure out why this is happening? The site is http://supah.com/

    I explored issues with settings on permalinks and .htaccess so far. I'm totally frustrated and on my 5th day of "trying stuff" to totally re-install the entire site and database (to fix from a pharma hack.)

  2. The Grey Parrots
    Member
    Posted 1 year ago #

    There might be some plugin installed / some restriction in your .htaccess settings thats why any url got redirected to home page.

    Checked link: http://supah.com/archives/portfolio_category/
    available-paintings-store

    Type of redirect: 301 Moved Permanently
    Redirected to: http://supah.com/

  3. supah
    Member
    Posted 1 year ago #

    i deactivated all plugins and the problem still happened. I am on a hostway hosting account. (i don't know if that is an issue, but I saw people with strange WP issues using godaddy.)

  4. supah
    Member
    Posted 1 year ago #

    here is my .htaccess file - i'm not sure why the code is repeated.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPressaccess */.??* *~ *# */HEADER* */README* */_vti*
    
    # disable the server signature- helps with preformance
    ServerSignature Off
    
    # since it's out of fashion to use www- redirect URLs to non-www
    Options +FollowSymLinks
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.website\.com$ [NC]
    RewriteRule ^.*$ http://website.com%{REQUEST_URI} [R=301,L]
    RewriteBase /
    # keep the URLs clean:
    # if someone asks for index.php- rewrite the URL without it
    RewriteRule ^(.*?)/?index\.php$ $1 [NC,R=301,L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    <Files wp-config.php>
    	Order Allow,Deny
    	Deny from all
    </Files>
  5. The Grey Parrots
    Member
    Posted 1 year ago #

    Kindly keep this part only and try it once

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    <Files wp-config.php>
    	Order Allow,Deny
    	Deny from all
    </Files>
  6. supah
    Member
    Posted 1 year ago #

    i deleted ithemes security, saved your .htaccess and now SOME pages load!

    Only problem - the portfolio pages do not load. I'm much further than where i was.

    I don't understand why this would continue to happen. Since the pretty links are virtual directories, (there's no actual http://supah.com/portfolio/polly-siamese but that's how they used to load before I recreated the website) I don't understand how it works.

    Thank you grey - you have already helped me incredibly.

  7. The Grey Parrots
    Member
    Posted 1 year ago #

    It seems that you created some portfolio items in your WordPress admin panel. Those are visible here.

    This is one of those portfolio item.

  8. supah
    Member
    Posted 1 year ago #

    This suddenly loaded! Thank you! I don't really understand - perhaps it caught up with itself? I have no idea. Either way. I'm very grateful for your help and talking the issue out with me.

Topic Closed

This topic has been closed to new replies.

About this Topic