Support » Fixing WordPress » Only Full Size Images?

  • I’ve never really done much with the built-in WordPress media library. I tend to create a full size and thumbnail version of my photos with Paint.NET and upload both sizes to a folder and link to the full size from the thumbnail version.

    I’m setting up a blog for some people who don’t want to have to use an image editor like Paint.NET to generate thumbnails.

    After clicking “Add an Image” when editing a post or writing a new post, I select the image I want to upload. It uploads, says it’s crunching and all that good stuff. Eventually it’s added to the gallery for that post.

    However, when I go to actually insert the image into the post, the only size option I have is “full size”, which I obviously don’t want. It seems like thumbnail and the other sizes aren’t being created.

    Permissions on the wp-content/uploads folder is 777. The original size makes it into the uploads folder just fine, just never any other sizes.

    Can anyone advise on what I’m doing wrong or if I’m missing something?


Viewing 9 replies - 1 through 9 (of 9 total)
  • when u go to actually insert the image into the post, there will be four sizes .. thumb , medium ,large and full size

    check tht once and select after image gets crunched and use it as per ur requirements..

    tell us if u need any further help

    I see the four sizes, however only “full size” is able to be selected. And “full size” always says the size is 0x0 px. Either way, the only option I’m able to check is “full size”.

    I’ve also disabled all plugins, just to be positive that nothing else is messing with the uploading.

    Any other ideas?

    i think there is an issue with ur media uploader i suggest u to go with this

    if u think tht this is not the cause ..wait for some one to assist

    sorry dear , no idea on this

    OK, yah, I read all of that post. Nothing I tried seemed to help.

    I actually just tried using a new image and it worked, even though this new image is much larger than the others.

    Image 1: 59.8KB, 700×1001 – full size only
    Image 2: 48.7KB, 700×591 – full size only
    Image 3: 236KB, 1242×1864 – all sizes available

    Image 2 and Image 3 don’t have any size options other than “full size”. Image 3, the largest of the three images, has all the other size options available.

    It’s just very confusing why the others won’t work.

    you need to have JAVA add-on in Internet explorer by Sun microsysytems (or simply install JAVA plugin) and it should work.


    I am getting this same issue on a new 2.9.2 install. Images only upload full size. There are no other sizes available. I have tried disabling all plugins, switching to the default template, running as the admin, using the flash uploader and the native uploader, all with no luck.

    I have another wordpress 2.9.2 installation that has been running for a while and has been upgraded to 2.9.2. That site works fine with images. I can upload the same image using the same browser to both of my wordpress installations. My old site splits the image into the smaller sizes. The newly installed site does not. There is only the full size image. I have verified that the settings are the same for both sites.

    What can be the problem?

    I can upload files using wordpress media, and it also creates thumpnail images , medium size images in upload folder.My question is “How i want to access those Thumbnail images for my post”

    I found that I needed to install the php-gd Apache module on my server to enable image resizing on upload.

    Yes you are right have to install the php-gd Apache module but you did not say how. As root or sudo do:

    apt-get install php5-gd


    /etc/init.d/apache2 restart

    At lest on Ubuntu server.

    -Raymond Day

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Only Full Size Images?’ is closed to new replies.