WordPress.org

Forums

TinyMCE Advanced
Only first row showing? (16 posts)

  1. JoSal73
    Member
    Posted 1 year ago #

    Today wordpress updated and so did TinyMCE.

    When I look at the TinyMCE Advanced options page, it doesn't seem to have anything that would tell me to hide or show the icon rows. Is there something I'm missing or doing wrong?

    https://wordpress.org/plugins/tinymce-advanced/

  2. Harry Kobessen
    Member
    Posted 1 year ago #

    Same problem, updated WordPress to 3.9 and update the plugin. Only the first row is visible.

  3. bestoman
    Member
    Posted 1 year ago #

    Me too.

  4. Marypop
    Member
    Posted 1 year ago #

    Same here.

  5. cokeyblokey
    Member
    Posted 1 year ago #

    If I'm understanding your problem correctly, you're saying that when you're editing a post or page, only the first row of TinyMCE options are visible?

    If so then you need to press the 'Toolbar Toggle' button at the end of the row. The button looks like a series of little squares, arranged in rows. If that button is not visible then you need to make sure it's added to the first row within TinyMCE Advanced settings page.

    If I've misunderstood your problem then please ignore this advice :-)

  6. burlingtonpress
    Member
    Posted 1 year ago #

    That's not the issue. WordPress 3.9 literally only shows the first row of buttons, and ignores all other rows. This plugin will need to be updated.

  7. cokeyblokey
    Member
    Posted 1 year ago #

    Strange - I don't have that issue!

  8. JoSal73
    Member
    Posted 1 year ago #

    cokeyblokey, that solved the issue. I didn't even know that was an option. Not surprising as I don't make it a habit to read whatever user documentation is provided.

    I think it may be a better idea to maybe make the default to show instead of hide the extra toolbars...or at least make it really obvious that they are there but hidden and how to enable them.

    In any case, the extra rows are now visible for me. I just had to add stuff to the extra rows, save changes, then toggle the button and they appear.

    Thank you so much!

  9. lencw
    Member
    Posted 1 year ago #

    If the more technically minded thought there was a bug at play here, its very unlikely that the average blog user will guess that they have to press the toggle button to show all the rows of buttons. This is a backward step, and I for one can't see the logic of this change.

    As a minimum there needs to be a setting to enable or disable the toggle, and after the upgrade it should be set to off by default.

    Can the developers please review this change?
    Thanks

  10. bestoman
    Member
    Posted 1 year ago #

    I agree with lencw. My users are not going to know that there is a second row of buttons, and all the buttons are necessary to make best use of my webapp. My preferred functionality would be that if the toggle button is not present in the menu bar then all menu rows are shown by default.

  11. burlingtonpress
    Member
    Posted 1 year ago #

    You know, I have to apologize. I see the toggle button now. Unfortunately, my theme adds a bunch of buttons to the row, so now the toggle is mixed in with a bunch of stuff and very difficult to find.

    I too have a problem if this toggle button is the new format.

  12. bestoman
    Member
    Posted 1 year ago #

    I looked into this a bit more and think there's a quick css fix. This should display all menu bars by default, and still allow you to toggle them off:

    div[id*=-#mce_] {
    display: block !important;
    }

    I haven't had time to fully test this and to make sure it doesn't break anything else as I'm rushing out, so use at your own risk :)

  13. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    Sorry guys, its a known problem. To fix follow the instructions in this thread: http://wordpress.org/support/topic/toolbar-toggle-oddities?replies=6

  14. bestoman
    Member
    Posted 1 year ago #

    Just in case anyone tries my css above - sorry, I was terribly rushed and have only just noticed I pasted some utter gibberish by mistake :)

    This is what I intended:

    .mce-toolbar {
    display: block !important;
    }

  15. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    This should be fixed in the latest development version: http://downloads.wordpress.org/plugin/tinymce-advanced.zip (needs to be updated with FTP).

  16. Chris Borgman
    Member
    Posted 7 months ago #

    @bestoman Thank you!! That's what I was needing for cloning new sites for clients. ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.