Support » Plugin: Inline Related Posts » Only displaying at the end of the post

  • Resolved dwai1986

    (@dwai1986)


    The IRP plugin is only displaying at the end of each post. i have set the IRP interval to be 200 words. Yet this is not working. I have cloudfront enabled. is it due to this? could you please help?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author IntellyWP

    (@intellywp)

    Hi @dwai1986 ,
    Thanks for choosing IntellyWP products.

    Could you please send us the list of all plugin installed on your website and try to edit the following file:

    /wp-content/plugins/intelly-related-posts/includes/core.php

    and replace

    add_filter(‘the_content’, ‘irp_the_content’, 99999);

    with

    add_filter(‘the_content’, ‘irp_the_content’);

    Please let me know

    Thank you

    IntellyWP

    dwai1986

    (@dwai1986)

    Hi,
    I have changed the line of code to add_filter(‘the_content’, ‘irp_the_content’);
    But its still showing at the end only.

    The list of plugins that i am using are-
    1. 301 Redirects
    2. Ajax Load More
    3. Child Theme Configurator
    4. Classic Editor
    5. Dinosaur Game
    6. Display Posts
    7. Easy Updates Manager
    8. HD Quiz
    9. Inline Related Posts
    10. Insert Headers and Footers
    11. MaxButtons
    12. Newsletter
    13. OneSignal Push Notifications
    14. Page Builder by SiteOrigin
    15. PDF Embedder
    16. PHP Compatibility Checker
    17. PRyC WP: Add custom content to post and page (top/bottom)
    18. Reading Progress Bar
    19. Revive Old Posts
    20. Sassy Social Share
    21. Send Images to RSS
    22. Simple Custom Post Order
    23. Simple Side Tab
    24. SiteOrigin Widgets Bundle
    24. TablePress
    25. W3 Total Cache
    24. WHA Wordsearch
    25. WP Content Copy Protection & No Right Click
    26. WP Edit
    27. WPFront Scroll Top
    28. Yoast SEO

    dwai1986

    (@dwai1986)

    Hi..
    also please see below my settings for the IRP plugin..I have taken a screenshot of the same – https://drive.google.com/file/d/1JBeFO5RIgq7ualfpCq3QgcHWmGe98GnG/view?usp=sharing

    Plugin Author IntellyWP

    (@intellywp)

    Hi @dwai1986 ,

    This issue could be generated by the span tags inside your contents

    Could you please, after a plugin backup, edit the following file:

    /wp-content/plugins/intelly-related-post/includes/classes/html/HTMLContext.php

    and replaced the line 178 and 179

    $result->ensureWithoutPreviousBox=TRUE;
    $result->ensureWithoutNextBox=TRUE;

    with:

    $result->ensureWithoutPreviousBox=FALSE;
    $result->ensureWithoutNextBox=FALSE;

    Please let me know

    Thank you

    IntellyWP

    dwai1986

    (@dwai1986)

    Hi,
    Thanks a lot. It is working now after making the changes you suggested. I would request you to incorporate these changes in your next plugin update so that this problem does not recur again on the next plugin update. Thanks again 🙂

    Plugin Author IntellyWP

    (@intellywp)

    Hi @dwai1986 ,

    perfect, thanks for the update

    Have a nice day 😉

    IntellyWP

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.