Support » Plugin: RSS Aggregator by Feedzy - Powerful WP Autoblogging and News Aggregator » only displaying 5 posts in front end

  • Resolved Keirwatson

    (@keirwatson)


    (1) I had a problem yesterday: every time I edited the above page (which contains several Feedzy feed GB blocks), the number of posts to show would return to 5 so I would have to set them all over again.

    (2) This morning I updated Feedzy. But I found a new problem (see below). I rolled back to the previous version, flushed browser and SiteGround caches, deactivated AsyncJavascript, deactivated and reactivated the Feedzy plugin, but the problem persists.

    (3) The new issue seems related to (1): Now, the back end is remaining set correctly between edits, but the front end only shows 5 posts whatever I do! Yesterday the page above was showing 50 posts beautifully 🙁

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Keirwatson

    (@keirwatson)

    Further investigations suggest that during the update to 3.3.13 Feedzy GB blocks break, always outputting 5 posts on front end (fine on back end). Newly inserted GB blocks also remain fixed at 5 posts on front end (despite displaying correctly on back end).

    After rewinding to 3.3.12 any blocks previously affected by the update remain broken, but newly inserted blocks will function properly.

    I repeated the above to double check: updating to 3.3.13 – the same issues arose. I have rewound to 3.3.12 again and inserted the main feed in a new GB block at the top of the page to show it is working, but I have left the broken feeds in the lower half of the page for reference.

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson thank you for your detailed feedback! We have released a patch for this.

    Thread Starter Keirwatson

    (@keirwatson)

    Brilliant for fixing this so quickly guys!

    Sorry, but I’ve spotted a second problem in the backend.

    When setting a block to display a certain number of posts, but setting skip to a greater number, the back end display in Gutenberg editor shows no posts. (The front end gets it right). With no posts showing the block turns into an invisibly narrow block making it hard to edit.

    If you put in, say, display 10, but skip 9, then only 1 post is displayed in the back end, but 10 in the front end.

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson The below snippets seem contradictory to each other.

    When setting a block to display a certain number of posts, but setting skip to a greater number

    If you put in, say, display 10, but skip 9,

    Did you mean to say display 9 and skip 10? Can you please review your message?

    Thread Starter Keirwatson

    (@keirwatson)

    Let me clarify…

    If the skip is greater than or equal to display, then no posts show in back end. E.g Display 9 skip 10 displays 0 posts in back end, instead of 9

    Whereas if skip is less than display it displays (n= skip – display) posts e.g Display 10, skip 8 will display 2 posts in back end instead of 10.

    The correct number appear on the front end.

    Here are two screenshots showing the back end display: https://imgur.com/a/8qZ6a1k

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson I’m not sure why you want it to display 9 posts in the backend with display=9 and skip=10. Skip is an offset value and 0 will be displayed.

    Thread Starter Keirwatson

    (@keirwatson)

    No. That’s not how it’s supposed to work! It displays properly in the front end.

    The above setting (display=9 and skip=10) means “display the 9 posts that come after the 10 I have asked you to skip”, so should display posts No 11 to 19 in the feed i.e. skip post No. 1 – 10, then display the NEXT 9 posts (11 to 19).

    As I said, it works correctly in the front end where post 11-19 will show up fine, but in the backend it interprets this as meaning display post No. 1 to 9, but skip 1 to 10, so – as you say – it displays nothing BUT IT SHOULD!

    Likewise, if you set “display 5, skip 3”, in the front end it correctly displays post 4,5,6,7 & 8 (the five posts after skipping the first 3) but in the backend (editor) it will incorrectly display post 4 & 5 only.

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson unfortunately, your understanding is wrong. The skip means “display N and skip M posts out of the ones displayed”

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson Discussing this with the developers, I realize you are correct. The offset indeed means display N after skipping M. We will fix the issue in the back end. Thank you for pointing it out.

    Plugin Contributor contactashish13

    (@rozroz)

    @keirwatson we have released the new version of the plugin that should fix this. You may have to recreate the feed on the backend though. Let us know how it goes.

    Plugin Contributor contactashish13

    (@rozroz)

    We haven’t heard from you in sometime so marking this as Resolved. If you continue to face an issue, please create a new ticket. We’d be happy to help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘only displaying 5 posts in front end’ is closed to new replies.