Support » Plugin: All-in-One Event Calendar » Only certain events imported from .ics

  • Resolved Matt Scheidler

    (@matt6303)


    We have been importing a Google Calendar for 5.5 years. We are now noticing that some events are being imported and others are not. 7 new items were added to the Google Calendar yesterday; four imported successfully and are being displayed on the website while the other three were not.

    I have deleted the feed and added it again, to no avail. I also have clicked Refresh a number of times but that doesn’t seem to do anything – it just says “Refreshing” and spins forever.

    What might cause this behavior? I have imported the ICS file into Microsoft Outlook and the events in question display properly, so I know they’re present and (apparently) formatted properly.

    Thank you for your time!

Viewing 3 replies - 31 through 33 (of 33 total)
  • Original poster here. Sunny, thank you for the update, and I will be glad to test my site on 7.1 and 7.2 once the updated version of the plugin is available.

    I had to wait until my client’s down time between Christmas and New Year’s Day to be able to attempt an update, but I did so this morning and wanted to report success.

    I first tested and confirmed on my test site that a large calendar feed could successfully be imported when running PHP 7.2. Then I applied the same changes to the live multisite.

    • Updated to PHP 7.2.
    • Tried a manual Feed update on a large calendar (735 events) running 2.5.32 just to confirm it didn’t work…the “Refreshing” status persisted.
    • Updated plugin to 2.5.36.
    • Tried the manual Feed update again and the 735-event import completed successfully within 25 seconds.

    I will continue monitoring these sites over the coming days but it does appear as though the recent updates to the plugin have resolved my issue.

    Sunny, thanks to you and your team for staying with this issue. I’m very happy to finally move this multisite installation to PHP 7.2. As I said way back in my initial support request, this is the first and only issue we’ve had with AI1EC in nearly 6 years and we’re glad to continue using it.

    HI @matt6303,

    Thanks for the report and for confirming the fix worked!

Viewing 3 replies - 31 through 33 (of 33 total)
  • You must be logged in to reply to this topic.