Support » Plugin: Wordfence Security - Firewall & Malware Scan » ‘Only alert me when…’ not working

  • Resolved Dan

    (@dtrim)


    I have ticked the box to only be notified when an admin logs in from a new device or location, yet I’m notified every time I log in from the same computer at home.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @dtrim,

    Can you provide an example of the emails you are receiving? Do the same IP addresses appear in the emails?

    For example:

    First email: Administrator logged in from 1.1.1.1
    Second email: Administrator logged in from 1.1.1.1

    Dave

    Thread Starter Dan

    (@dtrim)

    Hi Dave,

    I’m confused why you need an example of the emails as you’ll know what’s contained in them, but yes the IP is always the same.

    Hi again!

    It helps to search for specific texts so I can see what is happening in the source code (it makes my debugging work easier).

    My guess is that your browser is clearing the cookie wf_loginalerted_***** or just deleting all cookies when it is closed.

    Can you try this:

    1. Open your browser and login to your website
    2. Press F12 -> Application -> Cookies -> Your site
    3. Verify that you see a cookie named wf_loginalerted_***** (the stars are random letters)
    4. Relaunch your browser
    5. Go to your site again and see if you can still see the wf_loginalerted cookie

    What it looks like for me: https://i.imgur.com/79qgoJU.png

    If it is not there, your browser might be deleting cookies on exit, so you can follow these steps (if on Chrome) to disable this:

    1. Chrome settings -> Advanced -> Content Settings -> Cookies
    2. Uncheck Keep local data only until you quit your browser

    For example: https://i.imgur.com/uIUwHod.png

    Dave

    Thread Starter Dan

    (@dtrim)

    Sorry only just seen that you’ve replied.

    I hate to tell you this but loginalerted isn’t there, so I checked my Chrome settings and it’s unchecked. So any ideas about what’s happening?

    Hi again,

    This seems to be an issue with the browser.

    Can you check the same settings page to make sure there are not Blocks, Clear on exit for your site?

    For example: https://i.imgur.com/L3Wmvt4.png

    Also please try logging in from another browser to see if the cookie shows up or not.

    Dave

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘‘Only alert me when…’ not working’ is closed to new replies.