Support » Plugin: BuddyPress Activity Plus » Only admins can post links

  • Resolved mongrel

    (@mongrel)


    Hey, all—

    Mind bending issue that I can NOT figure out. Only the Admin can post a link. Anyone when others try, the post just vanishes upon Submit. It “previews,” but then just doesn’t actually post.

    Non-admins can post/upload images, however.

    Thoughts?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thread Starter mongrel

    (@mongrel)

    Actually, one of the users is a Subscriber/Author (I’m using the “Members” plugin) and a Participant. She is able to post links just fine. I created a user with her exact permissions, yet that dummy user canNOT post links.

    Also, after looking deeper into the forums, I found a post about, apparently, the same problem, but he posted once and then never came back to answer questions, so the thread got closed. Someone’s advice was “Switch to default theme and disable all other plugins,” which I decided to try—no effect.

    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello there @mongrel,

    I can’t replicate the same on my end. Do users see any errors/messages when the link can’t be posted?

    Please add the following to the wp-config.php file:

    
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    

    Make sure that you insert this line BEFORE /* That's all, stop editing! Happy blogging. */ in the wp-config.php file.

    Try to replicate this issue again. This way all errors will be saved in the debug.log file inside the /wp-content/ directory.

    Upload the debug.log to cloud storage (Google Drive or DropBox) and share a link here.

    Let me know how it went!

    Cheers,
    Nastia

    i have this same issue ….a user with role of “author” cannot add links ..tried changing to editor role same thing …admin can post links though ..no errors when switching on wp_debug ..site is all SSL

    • This reply was modified 4 years, 4 months ago by ds123.
    Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello there @ds123,

    Per WordPress forum regulations, please create a new thread and describe the issue you have.

    Before posting it, deactivate all the plugins, except BuddyPress and BuddyPress Activity Plus to make sure that this issue is not caused by a plugin.

    Also, please let us know in a new thread, do users with “author” user role see any messages when they are trying to share a link? Or the link icon is missing from the activity feed?

    Kind regards,
    Nastia

    Thread Starter mongrel

    (@mongrel)

    Thank you, Nastia, for the reply! No errors are visible when a user (anyone below admin) attempts to insert a link. The debug log file is here:

    https://www.dropbox.com/s/p1oylkdzsy0ru73/debug.log?dl=0

    I don’t know much about code, but the word “protected” comes up a few times in the log. I’m hoping this is something as simple as me being stupid and improperly changing a setting and forgetting which one it was…

    Again, thank you so, so much for your time and attention.

    —J

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello mongrel,

    Have you performed quick plugin conflict test? I can only see Akismet logs in that debug so at this point we have to exclude that another plugin is preventing those links from showing.
    Let us know about results of the test.

    kind regards,
    Kasia

    Thread Starter mongrel

    (@mongrel)

    Hi, @kasia. Actually, I think I mentioned at the top of this thread that I deactivated all other plug-ins and switched to the default theme on my own before @nastia recommended switching on the debug-log.

    So, I’m wondering if there’s a role problem. A setting? A database problem? I just don’t know enough about code to go anywhere from here.

    Thanks!

    —J

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello mongrel,

    I’m sorry – I missed that part. There is no setting for this – it should work for user with subscriber role “just like that” – this is how it works on our sites.

    Can you try this solution https://wordpress.org/support/topic/only-admin-can-post-links-no-other-roles/#post-8925539

    If that will not work could I see this issue on your site? Can you also tell me what is PHP version on your server?
    You wrote that you used Members plugin for capabilities and roles. Issue with those type of plugins is that even if you disabled those, changes you made to roles are still valid. If you used that to modify roles of your user then we would know what were changes you made to them.

    kind regards,
    Kasia

    Thread Starter mongrel

    (@mongrel)

    Hey, @kasia

    Thanks for your help. So, I tried the solution you link to (deactivate the BuddyPress Activity Plus and try to post a link as a subscriber on BuddyPress Activity feed).

    I don’t know if you would say that “it worked.” Instead of the URL, the title of some posts are displayed as quoted, linked text. But there is no preview such as what is available when an admin posts.

    PHP is version 5.6.

    Deployment URL is:
    https://www.greylocktogether.org/groups/greylock-together/

    I don’t believe that I modified the default “subscriber” role using “Members,” but if Activity Plus functionality is dependent on a specific role permission, tell me what that is and I’ll check it immediately.

    Thanks!

    —j

    • This reply was modified 4 years, 4 months ago by mongrel.
    Thread Starter mongrel

    (@mongrel)

    Okay, so @wpmudev-support2 and @wpmudev-support9

    I should have said before that I was using the theme, Nirvana.

    In any case, I decided to just take the plunge and insert that snippet of code in to the functions.php file. The short answer, is that yes, it works. YAY! THANK YOU! Interestingly, however, the linked feature image displays on clicking “Add Link,” but if the image file size is large, the preview image is blacked out. Doesn’t matter to me as long as people take an extra two seconds to figure it out.

    NOW, the question is, because I am not using a child theme, will I need to update this file each time the theme is updated? Any other concerns you’d have?

    Again, THANK YOU!

    —mongrel

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello mongrel,

    Please take a look here https://wordpress.org/support/topic/only-admin-can-post-links-no-other-roles/#post-8946171

    It would be awesome if you could mark this thread as resolved 🙂

    kind regards,
    Kasia

    Thread Starter mongrel

    (@mongrel)

    Hey again, @wpmudev-support2

    As it happens, it actually does not fix the problem. It did for the test user I created, but not for several of the actual users. So I don’t really know what to do. It sounds to me like a database problem. I may rip the whole site down and start over. I don’t know.

    Thanks for trying.

    —mongrel

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello mongrel,

    I’m sorry to hear that it is not working for your users. As you can see here https://wordpress.org/support/topic/only-admin-can-post-links-no-other-roles/#post-8952202 my colleague Predrag notified our developers about the problem, so they should come up with the solution.

    kind regards,
    Kasia

    Thread Starter mongrel

    (@mongrel)

    Hi, again, Kasia (@wpmudev-support2)—

    I have one more clue to pass on that may help your developers:

    if the subscriber unchecks the box “No Thumbnail,” the link does NOT vanish upon clicking “Add Link.” The link is, in fact posted. Without the image, that kind of makes the functionality meaningless, BUT that’s the exact difference between an administrator ability and subscriber ability—that’s right at the point it breaks.

    So the issue would seem to be with the thumbnail. I’m betting that will mean something to someone smarter than I.

    —mongrel

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello mongrel,

    Can you go to Settings -> Discussion -> Comment Moderation and see if there is 0 inserted? If not, can you change value there to 0 and see if that will change anything?

    kind regards,
    Kasia

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Only admins can post links’ is closed to new replies.