WordPress HTTPS (SSL)
[resolved] Only Admin HTTPS functions (7 posts)

  1. chris vanderwall
    Posted 3 years ago #

    Hi -

    I've tried using the Force_SSL meta box with no success. From there I've tried to specify a URL such as 'jfk/jfk-instrument-testing-incoming-6th-graders-only/' but the URL Filter returns this after I've saved:

    I've also tried to make the full site secure using '/' but it returned \'/\'

    This is my first attempt with the plugin. I have, however, gotten the admin section of the site to https, just not anything else.
    Thanks for your assistance!


  2. Mike Ems
    Plugin Author

    Posted 3 years ago #

    Hmm, definitely an issue that only affects certain hosting environments. Is there any way I could test a fix on your server?

  3. chris vanderwall
    Posted 3 years ago #

    What would you suggest?
    When I've selected to secure a page via the widget in page edit, it just defaults back to http.
    In the HTTPS settings:
    SSL Host: http://www.plainfieldbandboosters.org
    port (blank)
    force ssl admin is checked
    force ssl exclusively is checked
    remove unsecure elements is checked
    debug mode is checked
    proxy is no
    admin menu is sidebar

  4. chris vanderwall
    Posted 3 years ago #

    the SSL Host does not include the http
    it actually reads 'www.plainfieldbandboosters.org'

  5. chris vanderwall
    Posted 3 years ago #

    Here is the page I'm trying to secure:


    'if ( typeof console === 'object' ) {
    console.log('[BEGIN WordPress HTTPS Debug Log]');
    console.log('Version: 3.3.6');
    console.log('HTTP URL: http://www.plainfieldbandboosters.org/');
    console.log('HTTPS URL: https://www.plainfieldbandboosters.org/');
    console.log('SSL: No');
    console.log('Diff Host: No');
    console.log('Subdomain: No');
    console.log('Proxy: No');
    console.log('Secure External URLs: [ https://s0.wp.com/wp-content/js/devicepx-jetpack.js, http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.0/themes/base/jquery-ui.css, http://ajax.googleapis.com/ajax/libs/jqueryui/1.7.0/themes/base/jquery-ui.css?ver=3.5.1, http://www.google.com/jsapi, https://s1.wp.com/wp-content/js/mustache.js, https://s0.wp.com/wp-content/js/postmessage.js, https://s0.wp.com/wp-content/mu-plugins/notes/notes-rest-common.js, https://s0.wp.com/wp-content/mu-plugins/notes/admin-bar-rest.js ]');
    console.log('Unsecure External URLs: [ ]');
    console.log('[END WordPress HTTPS Debug Log]');

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

    Served from: http://www.plainfieldbandboosters.org @ 2013-03-24 04:01:22 by W3 Total Cache -->'

  6. chris vanderwall
    Posted 3 years ago #

    Between using a relative path for my site logo and disabling woocommerce, that appears to have fixed the problem. Any known issues with WooCommerce? It appears to break the secure connection when trying to pull the customer's cart information...

  7. Mike Ems
    Plugin Author

    Posted 3 years ago #

    Anything that causes a warning on error has to taken on a case-by-case basis. It's not always as simple as it being an incompatibility between plugins. Often the issue is theme dependent or too specific to code into WordPress HTTPS. However not always. In my plugin, this module's purpose is to fix incompaitibilities with E-commerce plugins. If I can reliably reproduce an incompatibility, I will code in a fix for it.

    I don't have any issues with WooCommerce, but I also can't test every single configuration that exists. If you can show me what's going on, I can see about a fix. It's possible that the issue is theme dependent in which case I can tell you how to fix it with URL Filters.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.