Support » Plugin: Fetch Tweets » Only 1 tweet showing

  • hammersmithsociety

    (@hammersmithsociety)


    When I first installed fetch tweets a month or 2 ago, it showed the configured latest 2 tweets. Now it only shows the latest one tweet (no change in my config). Can you suggest any fix or workaround?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author miunosoft

    (@miunosoft)

    Hi,

    Are you using the Rotator template?

    If so check the value set to the Number of Items per Slide option which can be found via Dashboard -> Fetch Tweets -> Templates -> Rotator.

    Also check the value set to the <b>Item Count</b> rule option found by going to Dashboard -> Fetch Tweets -> Manage Rules -> Edit (of your choosing rule).

    Hope this helps.

    Thread Starter hammersmithsociety

    (@hammersmithsociety)

    No, not using the rotator template, and have set max number of items to show in the widget that calls the rule to 2, the default being 20.

    The thing is that it stopped showing 2 tweets without any changes to the site. It may be that Twitter has changed something in their API. Jetpack’s own plugin also has issues FYI.

    Plugin Author miunosoft

    (@miunosoft)

    Hmm,

    That’s strange. You say Jetpack has a problem. Is it the same issue?

    There could be various possible reasons such as a caching plugin, theme/plugin conflicts, or PHP/MySQL errors etc.

    I just created a rule with your screen name and the latest tweets are shown without any problems.

    Can you check the followings?

    1. Check the preview by going to Dashboard -> Fetch Tweets -> Manage Rules -> View (of your choosing rule). Tell me how many tweets you see there.

    2. Create another separate test rule with the same screen name, item count of 2, and the Plain template, then see tweets are shown without any problems.

    Let me know what you see.

    Thread Starter hammersmithsociety

    (@hammersmithsociety)

    I did a preview and I see 1 tweet fewer than the number configured (5 vs 6 configured)
    I increased the setting in the widget to 3, now I see 2 on the website.
    Is it an off-by-1 bug? Or change to zero-based count in the API or…?

    FYI The Jetpack bug is a problem where it has stopped showing the embedded part of the tweet, it only shows my own content – this also happened without changing anything, and they have been unable to fix it.

    Plugin Author miunosoft

    (@miunosoft)

    Probably, the second tweet is a reply and you have the option “Replies will be excluded” checked.

    Thread Starter hammersmithsociety

    (@hammersmithsociety)

    Yes I had the exclude option set as I didn’t want a reply. If I unset that option, reduce the widget count to 2 then I have the latest tweet and the reply. If I set the exclude option, I only have 1 tweet – the next tweet is missing. I have to set the count to 3 to get it.

    I don’t understand how the “max tweets” count is working in the widget – it appears to be counting the excluded tweet (the reply).

    Plugin Author miunosoft

    (@miunosoft)

    That’s right. It counts excluded tweets. So it is an expected behavior. That’s how Twitter API works and the plugin just gives those parameters to API requests.

    If this is not intuitive, I’ll consider a change to request tweets with a maximum count and filter them later. But I cannot guarantee when.

    Thread Starter hammersmithsociety

    (@hammersmithsociety)

    Yes, its not intuitive to me at least: I’m looking for something that mirrors the either “Tweets” or “Tweets and replies” that Twitter lists. I can’t really use filters if they have unexpected side effects like changing the count.
    The plugin is great apart from this little issue – thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Only 1 tweet showing’ is closed to new replies.