Support » Plugin: Share on Mastodon » Only 1 Image Sent Despite Settings set to ‘Max 4 Images’.

  • Using:
    Share On Mastodon v.0.17.1

    Only a single image is being sent to Mastodon on posts that contain one featured image and one in-content image.

    ActivityPub sees both images and sends both to my wordpress instance. I’d like Share On Mastodon to do the same for my personal mastodon account.

    Settings:

    • Max images > 4.
    • (Experimental (maybe this is why?)) In-post images > ‘Checked’.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter MindCreatesMeaning

    (@xizor)

    EDIT: This resolves itself when I deactivate all other plugins. I am conflict-tracking now and will report back.

    In the meantime, I notice the image order used by Share On Mastodon to display post images seems incorrect.

    • Images within content are displayed first on Mastodon.
    • Content Images are displayed in order or last image on page to first image on page.
    • Featured image is last image (or not displayed, depending upon Max Number of Images Settings).
    Plugin Author Jan Boddez

    (@janboddez)

    Hi, I did indeed just run a quick test and got it to work “okay.” As for the order … Seems to match for me, at least for “in-post”/“referenced”/“embedded” images (e.g., compare https://indieweb.social/@janboddez/111203978096188597 and https://jan.boddez.net/articles/quick-gallery-test), but I’ll look into the code, see if I can improve something.

    You are correct that these come before the featured image; I’ll see about flipping that around. “Attached” images (images uploaded when creating the post but not necessarily *in* it) come last.

    I’ll have a look, maybe we can also fix the documentation a bit, make this more clear.

    Plugin Author Jan Boddez

    (@janboddez)

    Had a quick look at the code and I think that for in-post images, it _should_ add them as they are encountered in the post content. Whereas “attached” images (which may or may not be the same images, the word “attached” is really kind of a misnomer, or confusing at best!) are probably added in the order they were uploaded (oldest first).

    If you ticked all three boxes, the order should probably be kept, but if you enabled “attached” images (and not “in-post” images), it could be different from how the images appear in the post. I think … If there’s no conflict with other plugins, etc.

    I’ll see if we can somehow improve this, still.

    Plugin Author Jan Boddez

    (@janboddez)

    Ran a couple tests and found another bug (in which large images that get rescaled during upload are missed by the “in-post” setting). 😀

    That said:

    • If (only) “attached” images is enabled, the order should be the order in which the images were uploaded.
    • If (only) “in-post” images is enabled, the order should be as they appear in the post.
    • If several options are enabled, it’s trickier: in-post images come first (as they appear in the post), followed by the featured image, followed by attached images (older images first). Then, any duplicates are removed. And finally, only the first four remaining images are kept. These four are the images that will be uploaded.

    Upcoming changes:

    • I’m going to put the featured image (if enabled) first.
    • Then in-post (if enabled) images, in order of appearance. I will update the settings page accordingly.
    • And then, if enabled, “attached” images (which is a bit of a misnomer, but I may have already mentioned that). Order will be oldest to newest, still.
    Plugin Author Jan Boddez

    (@janboddez)

    Content Images are displayed in order or last image on page to first image on page.

    I think this might be because they happen to also be attached images (i.e., were uploaded during post creation and not elsewhere, e.g., through the Media Library directly), and that you have the “attached” images setting enabled (but not the “in-post” images)?

    And that the order is in fact based on image (database) ID and thus upload order. Which happens to be … their order of appearance, yet reversed.

    And that this should resolve itself if you switched to “in-post” images … (If the plugin can find them! WordPress is a bit tricky in this regard.)

    At least that’s what the tests (and code) seem to suggest.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.