WordPress.org

Forums

ShareThis: Share Buttons and Social Analytics
onhover: false not working? (7 posts)

  1. Julianwave
    Member
    Posted 10 months ago #

    My client does not like the hover popups on the email and sharethis icon buttons. I thought to turn this off I should add onhover: false into the code as follows:

    <script charset="utf-8" type="text/javascript">var switchTo5x=true;</script>
    <script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
    <script charset="utf-8" type="text/javascript">stLight.options({onhover: false;"publisher":"wp.a927ca6e-0377-4c64-9366-cf9791a10b21"});var st_type="wordpress3.9.1";</script>

    but it has no effect so I guess I( must be doing it wrong.

    Could you let me know the right way please?

    Thanks

    https://wordpress.org/plugins/share-this/

  2. sharethissupport
    Member
    Posted 10 months ago #

    The code seems to be fine. General implementation is -
    <script type="text/javascript">stLight.options({publisher: "Publisher_key", onhover:false});</script>

    Please provide your website details so that we can check the behavior.

  3. Julianwave
    Member
    Posted 10 months ago #

    I've had another look and found out a bit more. What is happening is that I add in the "onhover: false;" bit in the "view & edit code" box and click save. It all looks ok at that point. However if I leave the cms screen ("6. your current configuration") and then return to it, the "onhover: false;" bit has disappeared from the code, which has reverted to its default auto generated state, so in other words my edit is not being saved properly even though it says it is at the time.

  4. Julianwave
    Member
    Posted 10 months ago #

  5. Julianwave
    Member
    Posted 10 months ago #

    Having said all the above, this is in fact showing in the page source

    <script charset="utf-8" type="text/javascript">var switchTo5x=true;</script>
    <script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
    <script charset="utf-8" type="text/javascript">stLight.options({onhover: false;"publisher":"wp.a927ca6e-0377-4c64-9366-cf9791a10b21"});var st_type="wordpress3.9.1";</script>

    although it is still having no effect.

  6. Julianwave
    Member
    Posted 10 months ago #


  7. sharethissupport
    Member
    Posted 10 months ago #

    Please make a change in your code -

    <script charset="utf-8" type="text/javascript">stLight.options({"publisher":"wp.a927ca6e-0377-4c64-9366-cf9791a10b21", onhover:false});var st_type="wordpress3.9.1";</script>

    And let us know if this works for your or not.

Reply

You must log in to post.

About this Plugin

  • ShareThis: Share Buttons and Social Analytics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic